
Chapter 5: Working Files 
This chapter discusses the creation, selection, and use of Working Files.  

Designating a file as a Working File instructs WinFrog to use that particular file for data 
retrieval or storage. There may be several different files of the same type on the computer’s 
hard drive. Designating a file as the Working File specifies that all entry and/or editing of that 
type of data will occur in that specific file. 

WinFrog’s Working Files are not different in content than any other non- working file. All 
WinFrog generated files contain text-based, comma separated ASCII format data. WinFrog can 
also utilize some other files whose formats are specified by their third party creators. WinFrog 
utilizes these various files for different purposes; some are used to store data while WinFrog 
uses others in graphic presentations, etc. 

Each WinFrog file has a unique three-letter file extension and contains different types of 
information. (See Appendix B: WinFrog File Formats for detailed information concerning the 
structure and contents of individual file types.) 

Some Working Files contain coordinate data. For example, a Working Survey Line file 
contains a list of individual lines that can be displayed on screen and tracked by the helmsman. 
Each line is independent of the others in terms of name, coordinates, color, etc. A Working 
Waypoints file contains a list of individual target points that can be displayed and tracked. Each 
waypoint is independent of the others in terms of name, coordinates, etc. 

Other Working Files are used only to refer to other WinFrog files that contain coordinate data. 
For example, the Working Data (.ALG) file simply contains a list of data (.DAT) files that 
have been created. These individual .DAT files contain the actual data fix information. 

WinFrog can access Working Files from anywhere on the computer, but to keep projects 
organized it is recommended that the Working Files be kept in a single Working Directory on 
the computer’s hard drive. When WinFrog was installed, default Working Files were created 
and stored in the default Working Directory named Navdata. You can use these default files 
for a project or create new files, as required. 
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Each of the different types of files used by WinFrog are easily identified by their three letter file 
extensions: 

File name Extension Contents 

Survey line .PTS node coordinates and attributes of each survey line 
Waypoint .WPT list of individual waypoints and their associated  
  attributes 
Data .ALG  list of individual data files  
Data .DAT contains automatic event information 
Seismic Sources .ASC list of individual Source files  
Source .SRC contains automatic event information 
Seismic Receivers .ALL  list of individual Receiver files  
Receiver .RCV contains automatic event information 
Logs  .LOG manual event information 
Picture  .PIC list of entities comprising a picture 
Charts .*** various 3rd party file types (.RML, .BSB, .HDR) 
CRDD Database .MDB Cable Route Design Database  
Xponders .XPT list of subsea transponders and their attributes 
Control Stations .CLS list of individual control stations and their associated  
  attributes 
Velocities .VEL profile of velocities at different depths 
Cable Events .CET manual event information 
Passwords .PWD security password information 

Selecting Working Files 
Working files are selected (or created) in two different ways, depending on which type is 
needed. The first (and quickest) way is by opening the Select Working Files dialog box. Use 
this method to select the more commonly used file types, i.e.: those files required in a typical 
hydrographic survey. 

Other, less commonly used, WinFrog files must be created by selecting the main menu item 
File, then New. The following sections detail both of these methods. 

Working Files Dialog Box 
The Working Files dialog box allows you to quickly select or create those working files most 
commonly used by WinFrog. 
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To Configure a Working File Using the Working Files Dialog Box 
1 From the File menu, choose Select Working Files. 

2 Select the working file type by selecting the corresponding radio button. 

3 Type the path of the desired directory into the Directory input field and the file name into 
the File input field. Note: the directory must already exist in order to use it, since WinFrog 
will not create a new directory. If a file name that does not already exist is entered, a new 
file will be created with the specified name. 

Or alternatively, click the Browse button, navigate to the desired directory, type the desired 
name in the File name: field and click Open.  

4 Repeat the above steps for all required file types. Once all the required Working Files have 
been specified, click OK. 
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Creating and Selecting Less Common Working Files 
Transponder (Xponder) files, Control Station (CtrlStation) files, Velocities files, and Cable 
Event files are required only on certain specific projects such as those involved with subsurface 
positioning and cable installation projects. These file types are configured and selected 
differently from other WinFrog files. 

To Create a .XPT, .CLS, .VEL, or .CET file 

1 From the File menu, choose New 

2 From the list of available file types, choose the desired option. 

For example, choosing the .XPT type brings up the following window: 

 

3 Click the Add button. 

4 Highlight the Comment/Name entry window and enter a temporary name. (You will delete 
this later). Click OK to close this and return to the previous dialog. You will see your entry 
reflected in the window. 

5 Click OK. A message will appear asking you if you want to save the changes. Select Yes. 

6 Once you select Yes, the Save As dialog box opens. Use the Save as type dropdown box to 
select the appropriate file type (.XPT for this example). Enter the name of the file, then 
click the Save button. 

You have now created a file of that specific type. 

7 Now, open this file in order to designate it as the Working File for files of that type. 

To Designate an Existing File as the Working File 
1 From the File menu, choose Open... 
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2 From the Files of type: dropdown menu, select the file type you wish to open. 

3 Navigate to the directory containing the file to be opened. 

4 Select the desired file. 

5 Click Open. 

6 At the upper left of the dialog box, check the Working box. 

This designates the file as the current Working File. Once a file is selected as the current 
Working File, WinFrog de-selects the previously selected Working File of the same type.  

You can now edit or delete the “false” entry made when the file was created. 

7 Click OK. 

You can now access the contents of the file in the same way as you access the more 
common Working Files. (Select File > Working Files...) 

To Create a .MKI file 
MakaiLay event files are used in conjunction with the MakaiLay interface drivers ‘Tycom 
System’ and ‘DW System’. The MakaiLay operator may download a selection of events as 
recorded by WinFrog during the cable laying. This may be done periodically, say every six or 
twelve hours. To enable recording of these events by WinFrog, the WinFrog operator must set 
up a working *.MKI file. This is done by selecting File > Edit Working Files > Makai Cable 
Event. The MakaiLay Event Files dialog appears. 

 

Use this dialog to first create a MKI file, then to select it as the working MKI file. View 
Working File provides a drop down list of the events in the file, one of which may be selected 
to view. View an Event allows you to select any MKI file and then view an event in that file. 

If a file is not set up, events from MakaiLay will not be stored. Ribbit can read these MKI files. 
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Working Survey Lines (.PTS) File 
A Survey Line is a series of points (at least 2) joined together in consecutive order to create a 
line. All Survey Lines are accessed via the Working Survey Lines (.PTS) File. Each line in 
the Working Survey Lines File is treated independently of the others. 

A Survey Line is made up of the following components: 

 The Start of Line, also referred to as the SOL. 
 Points where the line direction changes, referred to as Alter Courses or A/C's. A/C's are 

also referred to as Segments in the survey line coordinate entry window. 
 The End of Line , also referred to as the EOL. 

 
A Survey Line’s length can be as long as required, with as many A/C's as needed. All Survey 
Line records are regarded as multi-segmented lines. (A simple point-to-point line is treated as a 
multi-segmented line with only one segment). Each line record contains the name, start of 
segment coordinates, and end of segment coordinates for each segment (the end of segment 
coordinates of each segment are the start of segment coordinates for the next segment).  

Once a Survey Line has been defined in the Working Survey Lines file, it can be displayed in 
the Graphics and Birds Eye windows and a vehicle can be made to track the Survey Line. 
Once you have selected which line to track, WinFrog calculates such information as along-track 
distances from the SOL and EOL, as well as the cross-track distance perpendicular to the 
Survey Line. This information can then be displayed in one or more windows to assist the 
helmsman in keeping the vessel on course. 

Other survey line features allow you to add a radius to a point to create a curved line, and 
change the line color to help differentiate one line from another. You can also have WinFrog 
automatically generate Points on Line between two existing points and you can create lines 
parallel to an existing line or automatically generate a series of lines in a grid pattern about a 
fixed point. 

To Create or Select the Working Survey Lines File 
1 Select the main menu item File > Select Working Files. 

2 Click the radio button beside Survey Lines (.PTS). 

3 In the File field, enter the name of an existing .PTS file or a new name for the Survey Line 
file. 

4 In the Directory field, enter the location and name of an existing directory where the file is 
(will be) located. (Alternatively, use the Browse button to select the appropriate directory.) 

5 Click OK to complete the designation of the file as the Working Survey Lines file. 

To Select a Track Route (.TRK) as the Survey Line 
1 Select the main menu item File > Select Working Files. 

2 Click the radio button beside Survey Lines (.PTS). 

3 In the File field, enter the name of an existing .TRK  
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4 In the Directory field, enter the location and name of an existing directory where the file is 
located. (Alternatively, use the Browse button to select the appropriate directory.) 

5 Click OK to load the Track Route file as the Working Survey Lines file.   

The Track Route file will be read when you click OK and you will be notified of any 
anomalous data that is found. Once the file has been read, a .PTS file will be created in the 
same directory as the original .TRK file with the same name. If a file of that name already 
exists, you will be prompted to choose to overwrite the existing file, enter a new name for 
the file or cancel opening the new file. 

Editing the Contents of the Working Survey Lines File 
WinFrog stores Survey Line information in the Survey Lines (.PTS) file. This file contains all 
information pertinent to survey lines, including the line name(s) and all the coordinate points 
that define each of the line segments. 

To Edit the Working Survey Lines File 
1 From the File menu, choose Edit Working Files... > Survey Lines.  

WinFrog opens a dialog box whose title bar reflects the name of the Working Survey 
Lines File. 

This dialog window allows you to Add, Edit, and Delete survey lines. You can also create 
new survey lines parallel to an existing survey line, and create a grid of survey lines around 
a specific coordinate. 

Creating a New Survey Line 
A Survey Line is created by defining the coordinates of two or more points. These coordinates 
define the end points of each segment of the line. 

To Create a New Survey Line 
1 Click the Add button to open the Survey Line dialog box, as seen below. 
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2 In the Name field at the top of the Survey Line dialog box, enter a unique name for the 
line.  

Note: problems will arise if two lines have the same name; specifically, if you try to track a 
survey line that is listed twice in the same file, WinFrog will select the first line found in the 
file. 

3 Highlight Segment0 in the Line Segments area, indicating that you will be entering the 
coordinates for the Start of Line (SOL). 

4 Enter the coordinates in the coordinate field. 

These can be either manually entered or copied from the last position where a Graphics 
window cursor was positioned (clicked) using the Copy button. Also, the coordinates of 
waypoints can be copied to the coordinate field. To do this, select a waypoint from the drop 
down list and click the Copy From Waypoint button. 

This sets the coordinates of the first point of the new line. Determining which point is the 
Start of Line is significant because it determines the direction of the line, as well as which 
side of the line will be deemed the starboard or port side of the line.  
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5 Select Segment1 in the Line Segments list. 

6 Enter the coordinates of the end of the first segment of the line. 

You can also define this point by selecting the R/B checkbox to enter the Range and 
Bearing from the previous point. Ensure the distance units are correct and note that the 
bearing must be entered in degrees and decimal degrees (dd.dddd) format. If the point is 
below vertical datum (i.e. a depth) enter the elevation value as negative. 

7 To Add another point to the end of the survey line, click the Add Segment button. 

Enter the coordinates of the additional points. 

8 To Insert a point between two previously entered points, first highlight the Segment that 
you want the new point to precede, then click the Insert Segment button. Note: a new 
point is inserted in the coordinate listing just above the point that was highlighted. 

The coordinates of the newly added point must be edited to the desired value. 

9 Highlight the newly created Segment, then highlight and edit the coordinates as required. 

10 To Delete a point, highlight the appropriate segment and select Delete Segment. 

11 You can use WinFrog to generate “points on line” between two previously entered points, 
based on a defined maximum distance from a selected segment. First, highlight the segment 
that you want the new points to follow, then select the Insert POL’s button. The Create 
Points on Line dialog box appears, as seen below. 

 

WinFrog will generate points on the segment immediately following the selected segment 
using the inverse and direct algorithms for the selected Calculation Mode based on the 
entered Separation value. Note that the distance from the last new POL to the following 
original node may be less than the entered separation. 

12 Highlight the value in the entry window and type in the desired interval between points. 
Click OK. WinFrog will create as many points that will evenly fit between the existing 
points. 

13 The Line Colour panel displays the current colour assigned to the line. To change this, click 
the associated Edit button, select the desired colour and click OK. 
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14 The Vessel Approach Alarm panel allows you to select the line to be used for alarming if a 
vehicle comes within the specified distance. To configure this line to be used for this alarm, 
check the respective Enable box and enter the distance of closest allowed approach. Note 

that this alarm is not activated until the Line Alarm toolbar button ( ) is clicked. 

Note: The Line Information section of the survey line dialog box presents information 
pertaining to the selected segment. It also states the line tracking mode currently in affect, as 
configured via the main menu Configure – Units - Calculations option. The information 
displayed is based on this calculation mode and includes the following: 

• Segment Length along with the nodes that define the segment, e.g. in the example, 
Segment 3 is selected in the Line Segment list, this is defined by the nodes 2 and 3. 

• KP at Segment gives the Kilometer Post value at the end of the selected segment. 
If there is a curve at this node, the KP is given for the centre of the curve. 

• Total Length gives the total length of the line, including curves if they are present. 

• Seg Forward Azimuth gives the forward azimuth of the selected segment. 

• Seg Reverse Azimuth gives the reverse azimuth of the selected segment. 

15 Visibility of the line can be switched on or off by the selection of the Draw on Graphics 
Window checkbox. 

16 Click OK to close this window and save the changes. 

17 The line is added to the list of Survey Lines in the Working Survey Lines file, as shown 
below. 

 

To create additional Survey Lines, repeat this process giving the new Survey Lines unique 
names. 
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Overage Loop Option 
WinFrog supports the capability to generate the necessary alteration in the design route to allow 
for the laying of excess flexible pipe. This is referred to as an Overage Loop. This option is 
accessed via the Overage Loop button in the Line Segment panel and includes the option to 
preview the loop in the Graphics Window. 

To Apply an Overage Loop 
1 Select the appropriate line in the Survey Line dialog box and click the Edit button. 

2 Select the segment the overage loop is to be located on and click the Overage Loop button. 

 

3 In the Excess panel, enter the actual (true geographic) length of excess flexible pipe that is 
to be laid in the overage loop.  

4 In the TP1 panel, select the coordinate type (Geo or Grid) and enter the coordinate that the 
loop is to start at. This can be either manually entered or copied from the last position a 
Graphics Window cursor was positioned (clicked) using the Copy button. In either case, 
WinFrog calculates the point on the segment that is closest to the entered coordinate. 
Alternatively, the range from the node that defines the start of the selected segment can be 
entered by selecting the Range from Node n checkbox. This distance is entered in grid if 
the Grid radio button is selected and actual (true) if the Geo radio button is selected. 
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5 In the Maximum heading Deviation panel, enter the maximum deflection angle allowed 
for any tangent defining the overage loop components. 

6 In the Route Modification Type panel, select the type of overage loop to use. 

7 Click the Calculate/Preview Line button to calculate the overage loop and preview it any 
Graphics or Bird’s Eye window that is open. The previewed line is displayed in white. The 
calculated nodes are displayed in the Calculated Points panel. 

8 To clear existing overage loop nodes, click the Clear Current Modified Points button. 

9 To accept the overage loop, exit the dialog with OK. 

10 During the process, if at any time WinFrog determines that a problem exists, you are 
alerted. WinFrog will not let the overage loop calculation proceed if a problem exists. An 
example of this is if based upon the selected staring point and length of excess flexible pipe 
to lay results in an end of the overage loop that extends beyond the following node. 

It is important to note the following with respect to the overage loop option: 

• Only one overage loop can be added to a survey line. 

• The Overage Loop button is only active if the selected segment can support a loop. 
Thus when the last segment is selected, this button is disabled. 

• WinFrog keeps track of the overage loop nodes, including when saving to and loading 
from a survey line file. In the Survey Line dialog in the Line Segment panel, if an 
overage loop has been added to a line, the segment the loop was added to is indicated 
with an asterisk. 

• If a loop has already been added to a line, the Overage Loop button is only active when 
that segment is disabled. If another loop is to be added to the line, the existing loop 
must be cleared first. 

• The nodes associated with the overage loop become actual nodes in the survey line and 
thus are incorporated in line tracking calculations, including alongline, offline and KP. 

Defining Curves in a Survey Line 
As previously mentioned, Survey Lines are created by entering the coordinates of a series of 
points in consecutive order. The line that results simply joins those points together directly. 
However, some Survey Lines are defined with a certain curvature at these changes of direction. 
Pipe laying, for example, requires curves of a specific minimum radius at direction changes to 
accommodate for the rigidity of the pipe. 

You can enter a radius in the Radius Grid Distance field for any line points except the Start of 
Line and End of Line, since the curve radius must be applied to a segment that is between two 
other segments. The radius is used to describe an arc between the two line segments at the point 
selected in the Line Segments list. The point to which the radius is applied is understood by 
WinFrog to be the point of intersection (PI) of the two tangents between which the curve is 
applied. If mathematically possible, WinFrog inserts the curve tangentially into the survey line. 
A message will appear if the operation is not mathematically possible.  

To enter a radius, simply highlight the designated PI segment, and then enter a radius value in 
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the Radius Grid Distance window. Click in any other window to make the values in the Line 
Information windows change to reflect the changes. Now the KP at Segment and Total 
Length values are now calculated using the curve information, not the tangent information.  

Note: If you select the Scalable KP radio button, any radii entered for any line segment is 
ignored. Scalable kilometer post calculations are based on a line segment-to-line segment basis. 
(For more details see the Using the Kilometer Post Control section later in this chapter.) 

Creating New Survey Lines Parallel to Existing Survey 
Lines 
You can use WinFrog to generate new survey lines that are parallel to an existing survey line. 
This saves time that would otherwise be spent calculating Start of Line and End of Line 
coordinates and also ensures that the parallel line coordinates are correct. 

To Create Survey Lines Parallel to Existing Survey Lines 
1 Choose File > Edit Working Files... > Survey Lines to display the contents of the 

Working Survey Lines file. 

2 Click on the name of the existing Survey Line to which the new parallel lines will be 
created. 

3 Click the Parallel Lines button at the bottom of the dialog box. The Parallel Line dialog 
box appears, as seen below. 

 

4 Highlight the Offset field. This value defines the distance that the new lines will be offset 
from the chosen line. 

5 Enter the offset value. (Remember, in WinFrog, starboard offsets are entered as positive 
values and port offsets are entered as negative values.) 

Note: The port and starboard sides of the line are designated as viewed from the start of 
the line towards the end of line. 

If the original survey line contains a curve, the new parallel lines’ curve radii will be 
increased or reduced by the offset value. This may result in incorrect line segment 
calculations if the radius is reduced to zero (or less). 

6 Highlight the Multiple field. 

7 Enter the desired number of survey lines to be created parallel to the selected line. 

8 Click OK to close this window and initiate the creation of the new survey lines. 
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The Survey Lines dialog box now lists the newly created survey lines. The names of the 
new lines are based on the original line - appended with the offset value. You can highlight 
and edit any of these lines as described above. 

9 Click OK to close the Survey Lines dialog box and save the new lines. 

See the Operator Display Windows chapter for information about configuring the Graphics 
window to display the survey lines. 

Creating a Grid of Survey Lines Around a Point 
Some projects require a grid pattern of survey lines centered around a single point. WinFrog has 
the capability to automatically generate a grid of survey lines, based on user-entered values such 
as Center Position, the Number of Lines, Line Offset, Line Length, and Orientation. 

To Create a Grid of Survey Lines 
1 With the Working Survey Lines dialog box open, click the Calculate Grid button to 

display the PrePlot Grid dialog box, as seen below. 
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2 In the Grid Center/Orientation field, enter the coordinates of the center point of the grid. 

3 In the Azimuth field, enter the rotation of the grid in degrees - decimal degrees 
(dd.dddd). The rotation refers to the bearing of the N/S lines, as measured clockwise from 
North. 

4 In the N/S Line area, enter the Number of Lines that are required in the North/South 
direction. 

If an even number of lines is to be created, half the number of lines are created to the left of 
the center point and half the number of lines are created to the right of the center point. If an 
odd number of lines are to be created, one line will be created directly over the center point. 

5 In the N/S Line area, enter the length required for the lines in the Length of Lines field. 

The lines are created so that the center point coordinates will be perpendicular to the mid-
point of each line. 

6 Enter a value in the Spacing of Lines area that reflects the required spacing between lines 
in the North/South direction. This entry is always a positive value. 

7 In the Name Prefix field, enter the label you would like to precede each line name. For 
example, enter NS to indicate that these lines are North/South lines. WinFrog will add a 
numerical offset value to this prefix so that each line created will have a unique line name. 

8 To create the lines in the East/West direction, repeat Steps 4–7 for the fields in the E/W 
Line area. 

9 Once the parameters of the survey grid have been configured, click OK. WinFrog will 
generate the new lines and present them in the Working Survey Lines file. The newly 
created lines are completely independent and no different than any other lines contained in 
the Working Survey Lines file. You can edit each of the lines to change the name, color, 
etc. as required. 

Note: If the grid was generated incorrectly, all of the newly created lines must be deleted 
and the new lines re-generated following the same procedures as there is no single “re-
calculate grid” option. 

10 Click OK to save the changes to the Working Survey Lines file. The new survey lines are 
now also visible in the Graphics window, if configured to display them. 

Using the Kilometer Post Control in the Survey Line Dialog  
The KP (Kilometer Post) Control section of the Survey Line dialog box (as seen below) 
enables you to alter a Survey Line’s KP value by selecting either Scalable KP or Design KP. 
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The two KP Control options are discussed in detail below. 

Design KP 
Selecting the Design KP radio button in the KP Control area of the Survey Line dialog box 
results in kilometer post calculations executed based on a specified Starting KP user entry and 
increment selection (Increase or Decrease radio button). The value entered in the Starting KP 
field under the Design KP radio button always refers to Segment 0 (i.e. SOL) of a Survey 
Line. The selection of the Increase or Decrease radio buttons indicates whether the kilometer 
post value increases or decreases downline. Note: if curves are present in the survey line, the 
curves are included in the kilometer post calculations. 

Scalable KP 
Selecting the Scalable KP radio button in the KP Control area of the Survey Line dialog box 
allows you to input specific kilometer post values for each line segment. This entry then defines a 
scale factor used for that segment. This is often required when performing pipeline inspection 
surveys when, for example, a previous survey has assigned KP values for specific points along the 
structure. These assigned KP values do not necessarily match the actual calculated distance 
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between the respective points, but a KP value is entered so that subsequent surveys and inspections 
will be scaled to relate all information to the original KP data. 

To accomplish this, specific KP values (as calculated by the initial survey) are entered in the 
Segment field under the Scalable KP radio button for each line segment selected from the Line 
Segment list. WinFrog then calculates a scale factor for that segment and applies the factor to 
the actual (new) KP distances to determine a scaled segment KP value for any point along the 
route. 

Note: using the Scalable KP option requires a scale factor to be entered for every entered line 
segment. 

The respective calculated Segment Scale Factor value is displayed below the Segment field as 
data are entered for each line segment highlighted in the Line Segments list. (You must click in 
any other entry window in this dialog box to update the value to reflect a new KP entry). For 
example, if Segment2 is selected from the Line Segment list, the scale factor displayed is that 
for the first line segment (from Segment1 to Segment2). 

You can also enter a KP Scale Limit, which is used to test the calculated scale factor for each 
segment. The default value is 20 percent. When the line is assigned to a vehicle, WinFrog 
performs this test after the Survey Line dialog box is exited. If the test detects a violation after 
exiting the dialog box, a message box appears detailing the violation and requiring you to return 
immediately to the Survey Line dialog box to review and make adjustments as required. If the 
test detects a violation when the line is assigned to a vehicle, a message box displays detailing 
the violation, but the line is still assigned and operation continues. The onus is on you to review 
the line data and make the appropriate modifications. This test is applied at both points in the 
WinFrog operation to cover the case of reading a line file into WinFrog without actually 
reviewing the data from the Survey Line dialog box. 

Use FP/KP 
If you require the stationing of points to be displayed in foot units instead of kilometers, click 
on the Use FP button. Observe the change in the KP values to the standard equivalent. The 
button also changes to now display Use KP should you want to switch back in the other 
direction. 

Line Information 
The Line Information area on the lower right side of the Survey Line dialog box is intended to 
assist you in ensuring the correctness of the survey line data as it is entered. 

The Segment Length - to - displays the calculated line segment length for the line segment 
immediately before the highlighted point, as selected from the Line Segments list. 

The KP at SegmentX/MidCurveX displays the KP associated with the selected segment. If 
Design KP is selected, the KP is calculated, and in the case of a curve, the KP for the midpoint 
of the associated curve is shown; otherwise, the KP displayed is for the selected segment itself. 
If Scalable KP is selected, the KP is that entered for the selected segment.  

The Total Length field displays the total line length. If curves are present and the KP mode is 
Design, the length is calculated including the curves rather than just directly point to point. 

It is important to note that these calculations and all real-time line tracking calculations are 
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performed either on the map projection or the working ellipsoid, depending on the user 
selection in the Line Distance Calc area of the Units dialog box (Configure > Units). 

Event Control - SOL Event 
The SOL Event area in the Survey Line dialog box is used to assist the configuration of events. 
For more information, see the Eventing chapter. 

1 In the Number field under the SOL Event area, enter the event number to be used at the 
Start of Line. This number will be recalled as the default SOL event number when 
eventing is configured. 

2 In the Downline Distance field under the Sol Event area, enter the downline distance from 
the Start of Line to record the first event. This is usually left as 0.00. 

Vessel Approach Alarm 
If an alarm is desired when a vessel approaches a certain location, you can create a line then 
enable the Vessel Approach Alarm and enter a distance. When one of the points describing the 
vessel shape comes within the specified distance, the computer will beep at 2 Hz. Several lines 
can be enabled. To toggle the beeping on/off, click the “Line” button on the WinFrog tool bar 
(see the Speed Toolbar section in chapter 1). 

Editing the Working Survey Lines File 
For a variety of reasons, it may be necessary to modify one or more of the survey lines 
contained in the Working Survey Lines file. 

To Edit the Working Survey Lines File 
1 From the File menu, choose Edit Working Files... > Survey Lines. 
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To Edit a Survey Line 
1  Select the survey line to be edited.  

2 Click the Edit button. 

The Survey Line dialog box opened is identical to the dialog box that was used to create 
the survey line.  

3 Change any of the available survey line parameters desired. 

4 Click OK to save the changes when finished. 

Deleting a Survey Line 
Any existing survey line can be removed from the Working Survey Lines file. 

To Delete a Survey Line 
1 From the File menu, choose Edit Working Files... > Survey Lines. 

2 Select the survey line to be removed.  

3 Click the Delete button. 

4 Click OK to confirm the changes. 

Creating a Survey Line from the Working Waypts File 
WinFrog can create a survey line using information already entered into the Working 
Waypoints file. This saves time and increases the accuracy of the entries, especially when 
entering coordinates of long survey lines with many segment entries. 

To Create a Survey Line from Waypoints in the Working Waypoints File 
1 From the File menu, choose Edit Working Files... > Waypoints. 

2 Select the desired waypoints. 

Multiple waypoints can be selected by holding the Ctrl key on the keyboard and clicking 
the desired waypoints. You can also use the shift key with the mouse to highlight multiple 
waypoints listed in continuous order. 

3 Simultaneously press the Ctrl+Insert keys on the keyboard. This copies the coordinates of 
the waypoints to the computer’s “clipboard” memory. Click OK to close the Working 
Waypoints file. 

4 From WinFrog’s File menu, choose Edit Working Files... > Survey Lines. 

5 Simultaneously press the Shift+Insert keys on the keyboard. 

WinFrog creates a new survey line with the coordinates of the waypoints used as the 
coordinates of the survey line points (segments), in the same order that they were found in 
the Working Waypoints file. The name of the new survey line will default to the name of 
the first waypoint that was copied. You can now highlight and edit this survey line just like 
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any other line in the Working Survey Lines file. 

Creating a Survey Line from the Working Logs File 
WinFrog can create a survey line using information already entered into the Working Logs 
(.log) file. The Working Logs file contains event data collected manually by the user. Note that 
the manual events can contain one or multiple vehicle’s positions. If multiple positions are 
recorded, WinFrog uses all positions (in the order found) to create the new survey line. 

To Create a Survey Line from Events in the Working Logs File 
1 From the File menu, choose Edit Working Files... > Logs. 

2 Select the desired manual events. 

Multiple events can be selected by holding the Ctrl key on the keyboard and clicking the 
desired events. You can also use the shift key with the mouse to highlight multiple events 
listed in continuous order. 

3 Simultaneously press the Ctrl+Insert keys on the keyboard. This copies the coordinates of 
the events to the computer’s “clipboard” memory. Click OK to close the Working Logs 
file. 

4 From WinFrog’s File menu, choose Edit Working Files... > Survey Lines. 

5 Simultaneously press the Shift+Insert keys on the keyboard. 

WinFrog creates a new survey line with the coordinates of the events used as the 
coordinates of the survey line points (segments), in the same order that they were found in 
the Working Logs file. The name of the new survey line will default to the name of the first 
event that was copied. You can now highlight and edit this survey line just like any other 
line in the Working Survey Lines file. 

Creating a Survey Line using the Graphical Route Design 
Tool 
WinFrog’s Graphical Route Design tool can be used to create a survey line using coordinates 
obtained by simply clicking a series of points on the Graphics or Bird’s Eye displays. This tool 
provides a quick and easy way to create (or edit) survey lines whose coordinates need not be 
exact. (The accuracy depends on the Graphics display scale and the user’s ability to move the 
mouse to the exact coordinates required). The Graphical Route Design tool is found in the 
Speed Tool bar, as is the Display Position button. 

To Create a Survey Line using the Graphical Route Design Tool 
1 Before the Graphical Route Design tool is enabled, ensure that only the Display Position 

option is enabled in the Tool bar. (i.e., ensure that the zoom window and mouse pan buttons 
are not enabled). 
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2 Click on the Graphical Route Design icon. The Enter Route SurveyLine Name dialog 
box appears as seen below. 

 

3 Click in the top entry window and type in the name of the survey line to be created. 
WinFrog lists the names of the existing survey lines found in the Working Survey Lines 
file. You could also select and edit one of these lines instead of creating a new line. For this 
example we will create a new line. 

4 Click OK to close this window. Note that WinFrog now creates a new display (as shown 
below) that shows the coordinates of the mouse pointer as it moves about the limits of the 
Graphics display space. 

 

 As line points are specified on the Graphics display, this display will update to include the 
newly created line’s Total distance, and the last segment’s Distance and Azimuth. 

5 With the mouse pointer located at the desired location within the limits of the Graphics 
display, click the left mouse button. A red circle symbol is plotted at the selected location. 

6 Repeat step 5 to create new points on the survey line. 

7 New points on line can be created between two existing points. Move the mouse pointer to 
the desired location for the new point on line. Once the pointer is close enough to the line 
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segment, it changes is appearance from a straight cross to a circular design. Once the 
pointer has changed in appearance, you can click the left mouse button to create a new point 
on line. 

8 Any point on line can be moved or deleted. To move a point, move the mouse pointer over 
the desired point. When the mouse pointer is close enough to the point, it changes is 
appearance from a straight cross to a more ornate cross design. To move the point, simply 
hold down the left mouse button as you drag the point to its new location. 

 To delete a point, move the mouse pointer over the desired point. When the mouse pointer 
is close enough to the point, it changes is appearance from a straight cross to a more ornate 
cross design. To now delete the point, click the right mouse button and select Delete Point 
from the presented options. 

9 Once all line editing has been completed, you can save this line to the Working Survey 
Line file. Click the Graphical Route Design tool icon. A confirmation message appears 
asking “Do you want to save this route to the surveyline file?” Click the Yes button to save 
the line to the Working Survey Line file.  

 This line can now be found and edited in the Working Survey Line file. 

Tracking a Survey Line From the Working Survey Lines File 
Any vehicle in WinFrog can track any survey line contained in the Working Survey Lines file. 
When Survey Line Tracking is enabled, WinFrog constantly calculates the downline distance 
and perpendicular offline distance of the vehicle’s current tracking point. This information is 
displayed in the Vehicle Text Window, Helmsman Display, and Attitude Display. 

To Enable Survey Line Tracking 
1 Move the mouse point to within the limits of the Vehicle Text window and click the right 

mouse button. 

2 Select the Setup Line Tracking option. For more information on enabling Survey Line 
Tracking, refer to the Vehicles chapter. 

Working Waypoints (.WPT) File 
A “waypoint” is a singular target or destination point. For example, a waypoint could be the 
target position for a rig move, a rock, or even the pier. Once a Working Waypoints (.WPT) 
file is defined in WinFrog, waypoints can be added and edited. Once a waypoint has been added 
to the Working Waypoints file, it can be displayed on the Graphics and Bird’s Eye displays. 
Also, any of the points contained within the Working Waypoints file can be tracked. Tracking 
involves the calculation and display of the range and bearing from a vehicle to a waypoint. As 
the vehicle moves, WinFrog re-calculates and displays the range and bearing automatically in 
the Vehicle window. You can also configure WinFrog to sound an alarm when the vehicle 
crosses the boundary of a certain radius around a waypoint. 
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Adding a Waypoint to the Working Waypoints (.WPT) File 
To Create or Select the Working Waypoints File 
1 Select the main menu item File > Select Working Files... 

2 Click the radio button beside Waypoint (.WPT). 

3 In the File field, enter the name of an existing waypoint file or the name of new Working 
Waypoints file. 

4 Under Directory, type in the location and name of an existing directory. 

5 Click OK to complete the selection of the file as the Working Waypoints file. 

Creating New Waypoints 
There are two ways to add a waypoint to the Working Waypoints file. You can edit the 
contents of the Working Waypoints file and adding a new waypoint from that location or use 
the Add Waypoint shortcut in WinFrog’s Graphics and Bird’s Eye displays. Both methods are 
detailed below. 

To Create a New Waypoint from Within the Working Waypoints File 

1 From the File menu, choose Edit Working Files... > Waypoints. WinFrog opens the 
Working Waypoints file, shown below. 

 

2 Click the Add button. 
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3 In the Name field, type a unique name for the waypoint. 

4 Highlight the coordinate value in the Position entry window. 

5 Enter the coordinates of the waypoint. 

The coordinates can be either entered in geographic latitude and longitude (if the Geo radio 
button is selected) or in grid Northing and Easting (if the Grid radio button is selected). 

6 The Update Vehicle Tracking checkbox ensures that when the position of a waypoint is 
changed by the user while a vehicle is tracking that waypoint, the vehicle receives the new 
position. If the checkbox is left unchecked, the vehicle will resume tracking the old 
position. 

7 Type in an elevation for the waypoint in the Elevation field.  

Note: depths are negative values in this case. The elevation is used when viewing the 
waypoints in the Profile window and for dZ (delta depth) waypoint tracking calculations. 

8 Using the dropdown menu under the Icon area, select the icon to be used when displaying 
the waypoint in the Graphics and Bird’s Eye windows. 

The following choices are available: 

 Square 
 Circle 
 Triangle 
 Point 
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 Wreck 
 Sewer/Pipeline 
 Beacon - Triangular, Square, or Radio/Radar 
 Post/Pile 
 Rock 
 Light - Directional or General 
 Marker - General Buoy, Barrel Buoy, or Spherical Buoy 
 Marker - Bicolor 
 Bullseye 
 Anchor 
 Mine 
 Existing vehicle outline 
 

9 Enter a value in the Circle Radius field, if desired.  

This configures WinFrog to display a circle around the waypoint. This feature is useful 
when you want to stay a specified distance from a waypoint.  

Note: This does not automatically enable WinFrog’s audio alarm feature. That feature is 
enabled when you configure the tracking of a waypoint. (See the Waypoint Tracking 
section of Chapter 6 for more details.) 

10 In the Color area, click the Edit button to change the color of the waypoint. 

11 Visibility of the waypoint can be switched on and off by selection of the Draw on 
Graphics Window checkbox. 

12 Click OK. 

Repeat steps 2 through 9 to add more waypoints. 

For information about displaying waypoints in the Graphics window, see the Operator 
Display Windows chapter. 

To Create a Waypoint Using the Graphics Window Shortcut 
While this method of adding waypoints ultimately offers you more speed and convenience than 
the above mentioned “in file” method, it does initially require the configuration of various other 
WinFrog options, as detailed below. 

1 From the View menu, choose Graphics. (Note: the WinFrog’s Bird’s Eye display can also 
be used). 

2 Select the Display Position button in the toolbar. 

3 Move the mouse pointer to the desired location within the limits of the Graphics display, 
then press the left mouse button. A “cross” is now drawn at that location. 

4 Click the right mouse button and select Add Waypoint from the presented list of options. 

5 The Waypoint configuration window displays. (See the previous section for details about 
the contents of this window.)  

 Note: the coordinates shown in the Position entry window are automatically updated with 
the coordinates of the “cross” in the Graphics display. 
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6 Select OK to close this window and add this entry to the Working Waypoints file. 

For information about displaying waypoints in the Graphics window, see the Operator 
Display Windows chapter. 

Editing the Contents of the Working Waypoints File 
At some point during the project it may be necessary to modify one or more of the waypoints 
contained in the Working Waypoints file. 

To Edit a Waypoint in the Working Waypoints File 
1 From the File menu, choose Edit Working Files > Waypoints  

WinFrog lists all the previously created waypoints contained in the Working Waypoints 
file. 

2 Select the waypoint to be edited and click the Edit button.  

3 Make the desired changes. 

4 Click OK.  

WinFrog returns to the dialog box that displays all available waypoints. Repeat as required, 
then select OK to exit this window and save the changes. 

To Edit a Waypoint Using the Graphics Window Shortcut 
1 Select the Display Position button in the toolbar. 

2 Click in a Graphics window that has the Display Waypoints option enabled. (Note: the 
WinFrog’s Bird’s Eye display can also be used). 

3 Move the cursor close to an existing waypoint in this Graphics window, the cursor will 
change from a cross to a target cursor ( ) and double-click the left mouse button. 

4 The Waypoint dialog will appear displaying the information for the selected waypoint. 

5 Edit the waypoint and exit the dialog with OK. 

Note: Exiting with OK results in the Graphics windows updating to display the waypoint as 
edited and the Working Waypoint file to be updated to disk. Exiting with Cancel results in 
no changes taking affect. 

For more information, see the Operator Display Windows chapter. 

Removing Waypoints from the Working Waypoints File 
Previously created waypoints can be removed from the Working Waypoint file. 

To Remove Waypoints from the Working Waypoints File 
1 From the File menu, choose Edit Working Files... > Waypoints  

WinFrog lists all the previously created waypoints contained in the Working Waypoints file. 
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2 Highlight the waypoint(s) to be removed. (Use the Shift or Ctrl key to select multiple 
waypoints.) 

3 Click the Delete button. The selected waypoints are now removed from the Working 
Waypoints file. 

4 Select OK to close this window and save the changes.  

Using a Vehicle Shape as a Waypoint Icon 
The option to draw a vehicle shape at a target location provides a good graphical reference for 
moving a structure into place. WinFrog supports this feature. Existing vehicles can be selected 
to be used as a waypoint’s icon. When the Waypoint dialog is opened, the names of the current 
vehicles are listed after the standard icon options. Selecting one of the vehicle names enables 
the WF Vehicle Waypoint Settings group box allowing the configuration of how to position 
and orient the vehicle’s shape with respect to the waypoint coordinate. In this case, that 
vehicle’s shape is drawn at the waypoint, positioned and oriented as configured. The following 
details the configuration for this option. 

To Configure a Waypoint to Use a Vehicle Shape for an Icon 
1 Open the Waypoint dialog. 

 

2 Drop the Icon list down and scroll towards the bottom (the vehicles are listed after the 
standard icon options and prefaced with the term “VEH:”) and select the vehicle whose 
shape is to be used for the waypoint icon. 
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3 Enter the Forward/Aft and Port/Starboard offsets from the vehicle’s CRP to the point on 
the vehicle that is to be located at the waypoint coordinates. 

4 Enter the Orientation the vehicle icon is to be displayed with. Specify if this orientation is 
True (geographic) or Grid. 

5 If the vehicle shape is to be drawn with a dashed line (helps differentiate it from the actual 
vehicle), check the Draw with dashed line box. If this is unchecked the vehicle shape is 
drawn with a solid line. 

6 Exit the dialog with OK. 

Note: When a waypoint that is configured to use a vehicle shape as an icon is selected as a 
tracked waypoint, unlike waypoints configured for a standard icon that are drawn in 
the color of the tracking vehicle, a vehicle shape icon is drawn in the color configured 
for the waypoint, not that of the tracking vehicle. This is to help prevent confusion 
when the actual vehicle is near the waypoint. 

Note: If a waypoint’s icon was chosen to be a vehicle shape and subsequently that vehicle 
cannot be found in the current WinFrog vehicles list, e.g. it has been deleted or 
renamed, then the following will occur: 

1. When the Graphics windows refresh, the icon for that waypoint defaults to a square. 
However, the waypoint’s configuration is not changed. 

2. When the Waypoint dialog is opened for that waypoint, a message appears 
informing you that the previously selected vehicle is not available and that the icon 
has been reset to the default square. In order to update the Working Waypoint file 
accordingly, you must exit the Waypoint dialog using OK. 

3. If the change is not acknowledged and accepted as noted in 2 above, and if a 
vehicle with the same name is subsequently created, the waypoint will display using 
this new vehicle’s shape. 

Note:  See the Controlled Remote Tug Telemetry chapter for details regarding the use of a 
vehicle shape as a waypoint icon for controlled remote operations. 

Tracking a Waypoint Contained in the Working Waypoints 
File 
Any vehicle in WinFrog can be configured to track a Waypoint contained in the Working 
Waypoints file. When Waypoint Tracking is turned on, WinFrog calculates and displays real-
time range and bearing information from the vehicle’s current tracking point to the waypoint. 
This information can then be displayed in the Vehicle Text window. 

To Enable Waypoint Tracking 
1 Move the mouse pointer within the limits of the Vehicle Text window and click the right 

mouse button. 

2 Configure the presented options as desired.  

3 Click OK. 
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For more details about enabling Waypoint Tracking, see the To Track a Waypoint section in 
the Vehicles chapter. 

Creating a Drag Line Waypoint Set 
This consists of a set of five waypoints that provide a visual aid when running drag lines for 
bottom recovery. This was developed for retrieving cables that have a break at a known 
position, but can be adapted for general use. 

To Generate a Drag Line Set of Waypoints 
1  From the File menu, choose Edit Working Files... > Waypoints.  

2  Click the Drag Line button to display the following dialog. 

 

3 Enter the coordinates where the break is expected to be. This forms the base point from 
which the point where you want to cross the cable will be calculated. 

4 The Drag Number will be appended to the waypoint names allowing several sets of drag 
lines to be created. 

5 Enter the range and bearing to the crossing (from the point in step 3) where you want to set 
a drag line to cross the cable. Usually the bearing here is the direction that the cable is 
laying, one way or the other depending on which end you want to drag for. 

6 Enter the range and bearing (from the crossing point in step 5) to the start of the drag line. 
This becomes the reciprocal azimuth of the drag line. 

7 The Hooks on Bottom is measured from the crossing point toward the start of line.  

8 The Hooks on Cable is measured from the Hooks on the Bottom point toward the end of 
line. If you put the same number here as step 7, this point will be at the crossing point. 

9 The End of Drag is measured from the crossing point in the opposite direction from the 
start of line. 

10 Click OK to exit the dialog. Five waypoints will be created that lie on a line: BOLx, EST 
HOOKS ON BOTTOMx, CROSSx, EST HOOKS ON CABLEx, and EOLx. Where x = the 
drag line number entered in step 4. 
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Working Data (.ALG) File 
The Working Data (.ALG) File is used to reference related Data (.DAT) files. A .DAT data file 
contains data automatically collected during real time navigation. See Appendix B: WinFrog 
File Formats for detailed information concerning the structure and contents of data files. 

The size of the Working Data (.ALG) File is typically quite small because this file simply 
consists of the names (and locations) of .DAT data files. For example, in a hydrographic survey 
application you may wish to group all .DAT data files under a file name corresponding to the 
name of the project or survey area. For example, a working data file named Bay.ALG may 
contain a listing of data files, line1.DAT, line2.DAT, etc., corresponding to the data lines 
associated with that area. 

Unlike a working survey line, waypoint or picture file which typically contain design data, the 
Working Data (.ALG) file references data (.DAT) files that contain event data collected 
during a survey. The format and content of a Data (.DAT) file is identical to that used in a 
receiver (.RCV) file and a source (.SRC) file. These file types are different only in their 
extensions and the applications in which they are used. The use of these three different file 
extensions for identical types of files is to improve file organization and permit you to quickly 
ascertain the nature of the data stored in a working file.  

The contents of the Working Data (.ALG) file can be displayed in the WinFrog Graphics 
window. You can change the amount of .DAT data seen on the Graphics display by simply 
adding or unloading .DAT files from the Working Data (.ALG) file. Again, since the .ALG 
file only records the reference to the .DAT files, you are not actually adding or deleting the 
.DAT files, but instead simply adding or removing the reference to that file. 

The .DAT files are generated through automatic eventing based on time, distance, or an external 
trigger. Each .DAT file consists of the actual navigation event information recorded at those 
pre-configured intervals. You can edit the Working Data (.ALG) file to access the .DAT data 
files, then edit the .DAT files to read the individual event information. This editing can be done 
as the data are being collected or after eventing is finished, as desired. 

For more details about event generation, see the Eventing chapter. 

Note: The *.DAT files referenced in the *.ALG file are loaded into WinFrog memory when 
they are required, e.g. when they are displayed in the Graphics window or edited via the Edit 
Working Files > Data menu option. Once they are loaded into memory, they are not unloaded 
until the respective file is unloaded from the *.ALG file. Each *.DAT file is allowed a 
maximum of ten thousand events and during recording if this number is reached, a new file will 
be created and subsequent events placed therein.  

Creating or Selecting the Working Data (.ALG) File 
WinFrog stores the name and location of data (.DAT) files in the Working Data (.ALG) data 
file. 

To Create a New Working Data (.ALG) File 
1 From the File menu, choose Select Working Files. 
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2 Select the radio button to the left of Data (*.ALG).  

At the bottom of the Working Files dialog box, WinFrog displays the name of the current 
Working Data (.ALG) file in the File field and the file’s path in the Directory field. 

3 Enter the desired directory path into the Directory input field and the desired .ALG file 
name into the File input field. The directory must already exist since WinFrog will not 
create a new directory. 

Note: if you enter a file name that does not already exist, a new working file will be created. 
The directory must already exist since WinFrog will not create a new directory. 

 Or alternatively, click the Browse button, navigate to the desired directory, select the 
desired file from the list of .ALG files in the Working File box and then click Open.  

4 Click OK. 

Adding a Data (.DAT) File to the Working Data (.ALG) File 
After the Working Data (.ALG) file has been defined, you can then specify which Data 
(.DAT) files are to be referenced by that particular Data (.ALG) file. 

To Add Existing Data (.DAT) Files to the Working Data (.ALG) File 
1 From the File menu, choose Edit Working Files... > Data. 
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2 Click Add. 

3 Navigate to the directory containing the .DAT data files to be added. 

4 Select the file to be added.  

5 Click Open 

6 Click OK. WinFrog returns you to the .ALG contents dialog window, now listing the newly 
added file. 

Note: At the bottom of the Working ALG file dialog there are two status lines. The first displays 
the sum of individual file sizes that are listed in the *.ALG file. The second line displays the 
number of events loaded from the selected file. If this file has not yet been loaded, this line 
displays File not loaded. 

To Create Data (.DAT) Files 
WinFrog’s data (.DAT) files can only be created by configuring Automatic Eventing. The 
following is a brief explanation of how to start automatic eventing. See the Eventing chapter for 
more information on generating Automatic Events. 

1 From the Configure menu, choose Data Events > Setup. 
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2 In the Trigger area, select the desired interval radio button and enter the desired event 
interval. 

3 In the Record Type area, select the Data Logging (.DAT) radio button or the 
Hydrographic (.DAT) radio button, as required.  

4 In the Event Start area at the bottom of the Event Generation dialog box, select either 
Auto Start or Manual Start. 

5 Click OK. 

6 If you selected the Hydrographic radio button, the Distance Fixing dialog box will 
display. If you selected the Data Logging radio button, the Event Secondary 
Configuration dialog box will display. In either dialog box, configure any remaining 
parameters. WinFrog appends the appropriate three letter file extension, .DAT, when the 
file is created. 

For detailed information about events and configuring these dialog boxes, see the Eventing 
chapter. 

7 Click OK to close this window and create a .DAT file. 
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Editing the Working Data (.ALG) File  
You can easily modify any parameter of the .DAT data contained in the Working Data (.ALG) 
file. 

To Edit Data Contained in the Working Data (.ALG) File 
1 From the File menu, click Edit Working Files... > Data. 

2 Select the .DAT file to be edited. 

3 Click Edit. 

The .DAT dialog box opens, listing all of the events within that data file. 

The event (fix) numbers correspond to the numbers generated during automatic eventing. 

4 Select the desired event. 

5 Click Edit. 

 

 
6 Edit the desired parameters. 

7 Click OK to save the changes and close this dialog box. 

To Add data to the Working Data (.ALG) File 
1 From the File menu, click Edit Working Files... > Data. 

2 Select the .DAT file to be edited. 

3 Click Edit. 

5-34  WinFrog User’s Guide – Working Files 



The .DAT dialog box opens, listing all of the events within that data file. 

The event (fix) numbers correspond to the numbers generated during automatic eventing. 

4 Click Add. 

5 The Event dialog box displays (detailed above) with empty parameter fields. Enter the 
desired parameters. 

6 Click OK to save the changes and close this dialog box. 

To Delete data from the Working Data (.ALG) File 
1 From the File menu, click Edit Working Files... > Data. 

2 Select the .DAT file to be edited. 

3 Click Edit. 

The .DAT dialog box opens, listing all of the events within that data file. 

The event (fix) numbers correspond to the numbers generated during automatic eventing. 

4 Select the desired event. 

5 Click Delete. 

Creating a Histogram of Data (.DAT) File Events 
If the .DAT file fix data were acquired while line tracking was enabled, the crosstrack error data 
(in a .DAT file contained in the Working Data .ALG file) may be viewed as a histogram. A 
histogram for an entire line can be viewed to quickly ascertain the general accuracy, in terms of 
line tracking, at which the line was run. 

To Generate a Histogram of Offtrack Data from a Data (.DAT) File 
1 From the File menu, choose Edit Working Files... > Data. 

2 Select the .DAT file for which the histogram is to be created. 

3 Click the Plot button. 

A plot of the cross track (offline) histogram for that source file is generated and displayed. 

The number of bins and their sizes can be modified using the two scroll bars. 

Monitoring the Working Data (.ALG) File 
The size of the *.DAT files and the number of these that are currently loaded into WinFrog’s 
memory can affect the performance of WinFrog with respect to responsiveness to mouse clicks 
and slow Graphic window refreshes. If a large amount of memory is used to hold this data, the 
performance can be degraded. 
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When WinFrog is launched or a configuration file is loaded, the *.ALG file is opened and the 
size of the individual files that are referenced is determined and used to calculate a cumulative 
total size for the respective *.DAT files. If this total size exceeds 5MB, you are alerted to the 
potential for degraded performance due to an excessive amount of memory required to load all 
of the files. It is recommended that the *.ALG file is edited to remove those files that are not 
required. 

The file size of each individual event file is limited to 10,000 events (v3.9.41). This makes it 
more efficient to draw the events in the Graphics windows and makes it easier for the user to 
unload individual files. However, for long projects the accumulation of these files can still use 
up available memory to the point where WinFrog can no longer function properly. Although it 
seems that the accumulated size of the *.DAT files can reach 150MB without adverse effects, 
we recommend unloading older *.DAT files in order to keep the accumulated size of all the 
*.DAT files loaded below about 50MB. The amount of memory used is displayed on the 
Data.ALG dialog assessed from File > Edit Working Files > Data. 

Working Seismic Sources (.ASC) File 
The Working Seismic Sources (.ASC) file is used to reference related Source (.SRC) data 
files collected during a seismic survey. The size of the Working Seismic Sources file is 
typically quite small because the file simply consists of the names of recorded Seismic (.SRC) 
files. The purpose of this “two-tiered” system is to improve the organization of the typically 
large data sets produced when undertaking a seismic survey. 

WinFrog also organizes Seismic Sources (.SRC) and Data (.DAT) using the same two-tiered 
file structure; .SRC data are referenced in the Seismic Sources (.ASC) file, and .DAT data are 
referenced in the Data (.ALG) file. This file structure was implemented for projects such as an 
Ocean Bottom Cable (OBC) seismic project, for example, where all three (source, receiver, and 
data) files could be used. You can quickly ascertain the nature of the data stored in a working 
file simply by looking at the three-letter file extension. See the WinFrog File Formats 
appendix for detailed information concerning the structure and contents of .SRC, .RCV, and 
.DAT files. 

Unlike Working Survey Lines, Waypoints, and Picture files, which contain design data, the 
Working Seismic Sources (.ASC) File references Seismic (.SRC) files that contain event data 
actually recorded by WinFrog during navigation. You can edit any one of these individual 
events by editing a .SRC file contained in the Working Seismic Sources (.ASC) file. (The 
same is true for the contents of the Working Seismic Receivers (.ALL) file and Working Data 
(.DAT) file). 

The contents of all three data types can be displayed in WinFrog Graphics or Bird’s Eye 
windows. 

The data contained in these files are generated through automatic eventing based on time, 
distance, or an external trigger. For details about event generation, see the Eventing chapter. 

Note: The *.SRC files referenced in the *.ASC file are loaded into WinFrog memory when they 
are required, e.g. when they are displayed in the Graphics window or edited via the Edit 
Working Files > Data menu option. Once they are loaded into memory, they are not unloaded 
until the respective file is deleted from the *.ASC file. 
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Creating the Working Seismic Sources (.ASC) File 
Seismic Sources (.ASC) files store the name and location of Source (.SRC) files. The 
Working Seismic Sources file contains all information pertinent to access a Source file for 
both “real-time” data collection and retrieval purposes. 

To Create the Working Seismic Sources File 
1 From the File menu, choose Select Working Files. 

 

2 Select the radio button to the left of Seismic Sources (*.ASC).  

At the bottom of the Working Files dialog box, WinFrog displays the name of the current 
working shot points file in the File field and the file’s path in the Directory field. 

3 Enter the path of the desired (existing) directory into the Directory input field and the file 
name into the File input field.  

Note: if you enter the name of a file that does not already exist, a new working file will be 
created. 

 Or alternatively, click the Browse button, navigate to the desired directory, select the 
desired file from the list of .ASC files in the Working File box and then click Open.  

4 Click OK. 

Adding Source Files to the Working Seismic Sources 
(.ASC) File 
You can define which Source (SRC) files are to be referenced by the Working Seismic 
Sources (.ASSCC))  file.  
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To Add Existing Source Files to the Working Seismic Sources File 
1 From the File menu, choose Edit Working Files... > Seismic Sources. 

2 Click Add. 

3 Navigate to the directory containing the source (.SRC) files. 

4 Select the source file(s) you wish to add. 

5 Click Open. 

6 Click OK. 

 

The Source (.SRC) file will now appear in the Working Seismic Sources (.ASC) file. 

Note: At the bottom of the Working ASC file dialog there are two status lines. The first displays 
the sum of individual file sizes that are listed in the *.ASC file. The second line displays the 
number of events loaded from the selected file. If this file has not yet been loaded, this line 
displays File not loaded. 

To Configure WinFrog to Create Source (.SRC) Files 
WinFrog’s data (.SRC) files can only be created by configuring automatic eventing. The 
following is a brief explanation of how to start automatic eventing. See the Eventing chapter for 
more information on generating automatic events. 

1 From the Configure menu, choose Data Events > Setup. 
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2 In the Record Type area, select the Source (.SRC) radio button. 

3 In the Trigger area at the top left of the Event Generation dialog box, select the trigger 
option and interval value required. 

4 In the Event Start area at the bottom of the Event Generation dialog box, select either 
Auto Start or Manual Start. 

5 Click OK. 

6 The Distance Fixing dialog box displays in which you can configure any remaining 
parameters. WinFrog appends the appropriate three-letter file extension, .SRC, when the file is 
created. 

For detailed information about events and configuring these dialog boxes, see the Eventing 
chapter. 

7 Click OK to close this window and create a .SRC file. 

Editing the Working Seismic Sources (.ASC) File  
You can modify Source (.SRC) event data contained within the Working Seismic Sources 
(.ASC) file. Any individual parameter within the source record can be modified or edited.  
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To Edit Data Contained in the Working Seismic Sources (.ASC) File 
1 From the File menu, choose Edit Working Files... > Seismic Sources. 

The Working Seismic Sources dialog box displays with a listing of all Source file names 
referenced by the Working Seismic Sources file. 

2 Select the file you wish to edit. 

3 Click Edit. 

A dialog box opens listing all of the events contained within that Source file.  

The event numbers correspond to the numbering configured during the setup of the Event 
Generation dialog box. 

4 Select the desired event.  

5 Click Edit. 

 

6 Edit the desired parameters. 

7 Click OK to close this dialog box and save the changes. 

To Add Data to the Working Seismic Sources (.ASC) File 
1 From the File menu, choose Edit Working Files... > Seismic Sources. 

The Working Seismic Sources dialog box displays with a listing of all Source file names 
referenced by the Working Seismic Sources file. 

2 Select the file you wish to edit. 

3 Click Edit. 
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A dialog box opens listing all of the events contained within that Source file.  

The event numbers correspond to the numbering configured during the setup of the Event 
Generation dialog box. 

4 Click Add. 

5 The Event dialog box displays (detailed above) with empty parameter fields. Enter the 
desired parameters. 

6 Click OK to close this dialog box and save the changes. 

To Delete Data from the Working Seismic Sources (.ASC) File 
1 From the File menu, choose Edit Working Files... > Seismic Sources. 

The Working Seismic Sources dialog box displays with a listing of all Source file names 
referenced by the Working Seismic Sources file. 

2 Select the file you wish to edit. 

3 Click Edit. 

A dialog box opens listing all of the events contained within that Source file.  

The event numbers correspond to the numbering configured during the setup of the Event 
Generation dialog box. 

4 Click Delete. 

Creating a Histogram of the Source File Data 
After a Source (.SRC) file is created in the Working Seismic Sources (.ASC) file, its event 
data may be viewed in a graphical manner. Assuming that the data have been acquired with line 
tracking enabled, this feature permits the generation of a histogram of cross track error data. A 
histogram for an entire line can be viewed to quickly ascertain the general accuracy at which the 
line was run.  

To Generate a Histogram of Offtrack Data in a Source (.SRC) File  
1 From the File menu, choose Edit Working Files...> Seismic Sources to open the Working 

Seismic Sources dialog box. 

2 Select the Source File for which the histogram is to be created. 

3 Click the Plot button. 

A plot of the cross track (offline) histogram for that source file is generated and displayed. 

The number of bins and their sizes can be modified using the two scroll bars. 
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Monitoring the Working Sources (.ASC) File 
The size of the *.SRC files and the number of these that are currently loaded into WinFrog’s 
memory can affect the performance of WinFrog with respect to responsiveness to mouse clicks 
and slow Graphic window refreshes. If a large amount of memory is used to hold this data, the 
performance can be degraded. 

When WinFrog is launched or a configuration file is loaded, the *.ASC file is opened and the 
size of the individual files that are referenced is determined and used to calculate a cumulative 
total size for the respective *.SRC files. If this total size exceeds 5MB, you are alerted to the 
potential for degraded performance due to an excessive amount of memory required to load all 
of the files. It is recommended that the *.ASC file is edited to remove those files that are not 
required. 

Working Seismic Receivers (.ALL) File 
The Working Seismic Receivers (.ALL) file is used to refer to related Receiver (.RCV) files. 
A Receiver (.RCV) file contains data collected during Automatic Eventing based on time or 
distance down line. See the WinFrog File Formats appendix for detailed information 
concerning the structure and content of a .RCV Receiver file. 

The size of a Working Seismic Receivers (.ALL) file is typically quite small because the file 
simply consists of the names of Receiver (.RCV) files that are included in the working cables files. 

Unlike a working survey lines file, a working waypoints file, or a working pictures file, which 
typically contain design data (plans for a survey), the Working Seismic Receivers file 
references receiver (.RCV) files that contain event data recorded by WinFrog during 
navigation. The content and structure of a Receiver (.RCV) file is identical to that used in a 
Data (.DAT) file and a Seismic Source (.SRC) file. These file types are different only in their 
extensions and the application in which they are used. The reason WinFrog uses different 
working files for identical types of files is to improve file organization and permit you to 
quickly ascertain the nature of the data stored in a working file simply by looking at the three-
letter file extension. (For details about event generations, see the Eventing chapter.) 

You must designate a Working Seismic Receivers (.ALL) file before you can begin collection 
of Receiver (.RCV) data. This file can contain multiple Receiver (.RCV) files and each 
Receiver (.RCV) file can consist of multiple events. All data within the Working Seismic 
Receivers (.ALL) File can be displayed in WinFrog’s Graphics display. 

Note: The *.RCV files referenced in the *.ALL file are loaded into WinFrog memory when they 
are required, e.g. when they are displayed in the Graphics window or edited via the Edit 
Working Files > Data menu option. Once they are loaded into memory, they are not unloaded 
until the respective file is deleted from the *.ALL file. 

Creating a New Working Seismic Receivers (.ALL) File 
WinFrog stores the name and location of Receiver (.RCV) files in the Working Seismic 
Receivers (.ALL) file. These files contain all information pertinent to reference a Receiver 
(.RCV) file, including the file name and the directory tree to locate that file. 
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To Create a New Working Seismic Receivers (.ALL) File 
1 From the File menu, choose Select Working Files. 

 

2 Select the radio button to the left of Seismic Receivers (*.ALL).  

At the bottom of the Working Files dialog box, WinFrog displays the name of the current 
Working Seismic Receivers file in the File field and the file’s path in the Directory field. 

3 Enter the path of the desired directory into the Directory input field and the file name into 
the File input field.  

Note: if you type the name of a file that does not already exist, a new working file will be 
created. 

Or alternatively, click the Browse button, navigate to the desired directory, select the 
desired file from the list of .ALL files in the Working File box and then click Open.  

4 Click OK. 

Adding a .RCV File to the Working Seismic Receivers 
(.ALL) File 
After the Working Seismic Receivers (.ALL) file is selected, you can then define which 
Receiver (.RCV) files are to be referenced by that file. 

To Add Existing (.RCV) Files to the Working Seismic Receivers (.ALL) File 
1 From the File menu, choose Edit Working Files... > Seismic Receivers. 
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2 Click Add. 

3 Navigate to the directory containing the .RCV files to be added. 

4 Select the .RCV file to be added. 

5 Click Open. WinFrog returns you to the .ALL contents dialog box, now listing the newly 
added file.rcv. 

6 Click OK. 

Note: At the bottom of the Working ALL file dialog there are two status lines. The first displays 
the sum of individual file sizes that are listed in the *.ALL file. The second line displays the 
number of events loaded from the selected file. If this file has not yet been loaded, this line 
displays File not loaded. 

To Configure WinFrog to Create Receiver (.RCV) Files 
WinFrog’s receiver (.RCV) files can only be created by configuring automatic eventing. The 
following is a brief explanation of how to start automatic eventing. See the Eventing chapter for 
more information on generating automatic events. 

1 From the Configure menu, choose Data Events > Setup. 
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2 In the Record Type area, select the Receiver (.RCV) radio button. 

3 In the Trigger area, select the desired interval radio button and enter the desired Event 
Interval. 

4 In the Event Start area at the bottom of the Event Generation dialog box, select either 
Auto Start or Manual Start. 

5 Click OK. 

6 The Distance Fixing dialog box displays in which you can configure any remaining 
parameters. WinFrog appends the appropriate three-letter file extension, .RCV, when the file is 
created. 

For detailed information about events and configuring these dialog boxes, see the Eventing 
chapter. 

7 Click OK to close this window and create a .RCV file. 

Editing the Working Seismic Receivers (.ALL) File  
You can modify any parameter within a Receiver (.RCV) file via the Working Seismic 
Receivers (.ALL) File. 

WinFrog User’s Guide – Working Files  5-45 



To Edit Data contained in the Working Seismic Receivers (.ALL) File 
1 From the File menu, choose Edit Working Files... > Seismic Receivers. 

The .ALL dialog box contains a listing of all .RCV file names referenced by the Working 
.ALL file.  

2 Select the file to be edited. 

3 Click Edit. 

A dialog box opens listing all of the events contained within that file.  

The event numbers correspond to the numbers generated by WinFrog during Automatic 
Eventing.  

4 Select the desired event. 

5 Click Edit. 

 

6 Edit the desired parameters. 

7 Click OK. 

To Add Data to the Working Seismic Receivers (.ALL) File 
1 From the File menu, choose Edit Working Files... > Seismic Receivers. 

The .ALL dialog box opens containing a listing of all .RCV file names referenced by the 
Working .ALL file.  

2 Select the file to be added to. 

3 Click Edit. 
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A dialog box opens listing all of the events contained within that file.  

The event numbers correspond to the numbers generated by WinFrog during Automatic 
Eventing.  

4 Click Add. 

5 The Event dialog box displays (detailed above) with empty parameter fields. Enter the 
desired parameters. 

6 Click OK. 

To Delete Data from the Working Seismic Receivers (.ALL) File 
1 From the File menu, choose Edit Working Files... > Seismic Receivers. 

The .ALL dialog box opens containing a listing of all .RCV file names referenced by the 
Working .ALL file.  

2 Select the file to be edited. 

3 Click Edit. 

A dialog box opens listing all of the events contained within that file.  

The event numbers correspond to the numbers generated by WinFrog during Automatic 
Eventing.  

4 Select the desired event. 

5 Click Delete. 

Creating a Histogram of the Seismic Receivers (.ALL) File 
After a Receiver (.RCV) file has been created or added to the Working Seismic Receivers 
(.ALL) file, its line tracking data may be viewed in a graphical manner. Assuming that the data 
have been acquired with line tracking enabled, this feature permits the generation of histogram 
of cross track error data. A histogram for an entire line can be viewed to quickly ascertain the 
general accuracy at which the line was run. 

To Generate a Histogram of Offtrack Data in a Receiver (.RCV) File  
1 From the File menu, choose Edit Working Files... > Cables to open the Working Cables 

dialog box. 

2 Select the Receiver file for which the histogram is to be created.  

3 Click the Plot button. 

A plot of the cross track (offline) histogram for that source file is generated and displayed. 
The number of bins and their sizes can be modified using the two scroll bars. 
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Monitoring the Working Seismic Receivers (.ALL) File 
The size of the *.RCV files and the number of these that are currently loaded into WinFrog’s 
memory can affect the performance of WinFrog with respect to responsiveness to mouse clicks 
and slow Graphic window refreshes. If a large amount of memory is used to hold this data, the 
performance can be degraded. 

When WinFrog is launched or a configuration file is loaded, the *.ALL file is opened and the 
size of the individual files that are referenced is determined and used to calculate a cumulative 
total size for the respective *.RCV files. If this total size exceeds 5MB, you are alerted to the 
potential for degraded performance due to an excessive amount of memory required to load all 
of the files. It is recommended that the *.ALL file is edited to remove those files that are not 
required. 

Working Logs File 
The Working Logs (.LOG) file stores “Manual Events” that are generated by the user with the 
press of a key. Manual Events are a “snapshot” of the navigation information at any particular 
instant of time, and include data such as vessel position, speed, heading, course over 
ground/course made good, etc. See the Eventing chapter for more details on Manual Events. 

The Graphics and Bird’s-Eye windows can be configured to display the Manual Events 
recorded in the Working Logs File. Manual Events can also be tracked in the same way as 
Waypoints. After the survey, the .LOG file data can be used in post-processing, as all other 
WinFrog data. 

To Create or Select the Working Logs (.LOG) File 
1 Select the main menu item File > Edit Working Files... 

2 Click the radio button beside Logs. 

3 In the File entry field, enter the name of an existing .LOG file or a name for the new picture 
file. 

4 In the Directory entry field, enter the location and name of an existing directory where the 
file will be located. 

5 Click OK to create (select) the Working Logs (.LOG) File. 

Editing the Contents of the Working Logs File 
Once Manual Events have been recorded, it may be necessary to access or edit one or more of 
the Manual Events contained in the Working Logs File. 

To Edit the Contents of the Working Logs File 
1 From the File menu, choose Edit Working Files... > Logs. 

WinFrog displays a list of all Manual Events contained in the Working Logs file. 

2 Select the item to be edited. 
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3 Click Edit. 

The Manual Event dialog box now appears, as seen below. 

 

The Manual Event dialog box allows you to modify all the displayed parameters except 
cable count. Printing of the event is only available when the log event is first created, not 
when being reviewed from the Edit Working Files item available from the File menu. The 
Print check box will always retain the setting that was in effect the last time the dialog was 
closed with OK. 

4 Highlight the desired parameter and change as required. 

5 Click OK to close this window and return to the Manual Event listing. 

Deleting a Manual Event from the Working Logs File 
Any Manual Event can be removed from the Working Logs file. 

To Remove a Manual Event 
1 From the File menu, choose Edit Working Files... > Logs. 

2 Select the Manual Event to be removed.  

3 Click the Delete button. 

4 Click the OK button to close this window and save the changes. 
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Working Picture (.PIC) File 
A WinFrog Picture (.PIC) file is a WinFrog-specific file that contains a series of points that are 
connected to create a line that can be seen in WinFrog’s Graphics displays. Picture file contents 
are somewhat similar to that of a Survey Lines file. The difference between the two is that 
survey lines are intended for vehicle tracking purposes, while picture files are used only to 
display linear information as a background reference. 

One example of a typical use for a picture file is to display the outline of a coastal area. 
Coastline coordinate information can be digitized from existing charts or even downloaded from 
the internet. This information (once formatted in the WinFrog specific format) can then be used 
to display the approximate location of the coastline in a selected area. 

Picture file information from unknown or unreliable sources such as these must be used with 
caution. Some low resolution data sets may oversimplify the actual shore details. You must also 
ensure that the geodetic datum used in the reference data source is the same one selected in 
WinFrog. Positional discrepancies of several hundred meters (between actual features and their 
plotted positions) could result if these matters are not addressed correctly. 

To Create or Select the Working Picture File 
1 Select the main menu item File > Select Working Files. 

2 Click the radio button beside Picture. 

3 In the File entry area, enter the name of an existing .PIC file or a name for the new picture 
file. 

4 In the Directory entry area, enter the location and name of an existing directory where the 
file is (or will be) located. 

5 Click OK to create (select) the Working .PIC File. 

Creating a Line in the Working Picture File 
With a Working Picture file now selected, the next step is to add the picture information. As 
mentioned above, a picture file contains a series of coordinated points that are joined together to 
create a line on WinFrog’s Graphics display. 

There are actually two main components that must be configured to be able to see the contents 
of the picture file. First, a new Picture Control item must be created. This defines the name, 
color, and style of the line. The second step is to add coordinated points to define the line’s 
location. A Picture Point item is a point that defines a node in the picture file. In the Working 
Picture dialog box, all Picture Point items listed after a Picture Control item will be 
associated with that control item and will have the same color and line style. 

1 Select File > Edit Working Files... Picture.  

The .PIC file dialog box appears, as seen below. 
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2 Click the Add Control button. 

The Picture Control dialog box opens, as seen below. 

 

3 Enter a unique name in the Name field.  

4 To change the color of the line, click the Edit button in the color area and select a different 
color from the available palette. 

5 Click OK to close the Picture Control dialog box. 

WinFrog adds this new Picture Control item to the list of items in the Working Picture 
(.PIC) dialog box. 

6 Click the Add button to bring up the Picture Point dialog box, as seen below. 
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7 In the Position field of the Picture Point dialog box, enter the coordinates of the first point 
of the line. 

The coordinates can be either entered in geographic latitude and longitude or in grid 
Northing and Easting. 

8 In the Pen area, select either the Down radio button or the Up radio button.  

If Pen Down is selected, a line will be drawn from the previous Picture Point to this 
Picture Point, using the color and style defined by the above mentioned Picture Control 
item. 

If Pen Up is selected, no line will be drawn from the previously entered Picture Point to 
this Picture Point.  

Note: the first Picture Point added to the file must be configured with Pen Up. Failure to 
do so will result in an errant line being drawn from some random point to this point. 

9 Click OK to add the Picture Point item to the Working Picture File. 

Add more points by repeating steps 6 to 9. 
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Creating a Circle in the Working Picture File 
With a Working Picture file selected, a circle can easily be drawn by clicking the Create Circle 
button.   

1 Select File > Edit Working Files... >Picture.  

The .PIC file dialog box appears, as seen below. 

 

2 Click the Add Control button. 

The Picture Control dialog box opens, as seen below. 

 

3 Enter a unique name for the circle in the Name field.  

4 To change the color of the circle, click the Edit button in the color area and select a 
different color from the available palette. 

5 Click OK to close the Picture Control dialog box. 

WinFrog adds this new Picture Control item to the list of items in the Working Picture 
(.PIC) dialog box. 

6 Click the Calculate Circle button. 
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The Picture Circle dialog box opens, as seen below. 

 

7 In the Position field of the Picture Circle dialog box, enter the coordinates of the desired 
center point of the circle. 

The coordinates can be either entered in geographic latitude and longitude or in grid 
Northing and Easting. 

Click the Copy button to copy the coordinates in the system clipboard into the Position field. 

8 In the Radius field enter the desired radius in meters of the circle to be drawn. 

9 Click OK to calculate the circle points and add these points to the Working Picture File. 

Add more circles by repeating steps 2 to 9. 

Importing Files 
Creating a complex picture in WinFrog can be a time consuming and error prone task, since you 
have to manually enter the coordinates of each point. WinFrog includes the ability to import two 
different types of drawing files and convert them to a picture file. This can save you much time 
and frustration in creating a picture file. 

WinFrog supports the following types of input files: 

• DPC Picture files 
• Pelagos DMS files 

To import drawing files into WinFrog: 
1 Select File > Import. This will open the Import File dialog box. 

2 Select the type of file to import using the appropriate radio button and click OK.  

3 This will open the standard Open dialog box. This can be used to select the desired file. 
Click the Open button to import the file. WinFrog will immediately start reading the 
drawing entities found in the file. 

4 Once the entities are all successfully loaded, WinFrog will create a new picture file. The 
picture file will have the same name as the input file with the file extension changed to 
.PIC. The file will be located in the Pictures subdirectory under the current project. 

5 If the file already exists, WinFrog will open a dialog box stating that the file already exists 
and asking if WinFrog should overwrite the file. Click OK to overwrite the file, or Cancel 
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to exit out of the import utility. 

6 When WinFrog has finished converting all entities found in the input file, the Import File 
Complete dialog box is displayed. Click OK to return to the main WinFrog menu. 

7 The imported picture file can then be used to display the imported information in the 
Graphics window. In addition, you can edit the control and point picture items as discussed 
in the section below.  

Editing the Working Picture File 
It is possible to modify any Picture Control or Picture Point item contained in the Working 
Picture File. 

To Edit the Working Picture File 
1 From the File menu, choose Edit Working Files... > Picture. 

2 Select the item to be edited. 

3 Click Edit.  

The Picture Control dialog box opens if the selected item is a Picture Control item and 
the Picture Point dialog box opens if the selected item is a Picture Point item. These 
dialog boxes are identical to those used when the item was originally created.  

4 Make the desired changes. 

5 Click OK to confirm the changes and return to the Picture Point File content listing. 

Removing an Item from the Working Picture File 
It is possible to remove a Picture Point item contained in the Working Picture File. 

To Remove a Picture Point from the Working Picture File 
1 From the File menu, click Edit Working Files... > Picture. 

2 Select the Picture Point item to be removed. 

3 Click the Delete button.  

4 Click OK to confirm the changes and return to the Picture Point File content listing. 

Working Charts (.RML) File 
The Working Charts (.RML) file contains raster image data that can be displayed in 
WinFrog’s Graphics and Bird’s Eye displays. These data can be loaded and displayed, but not 
edited. Three different formats of raster chart files can be loaded and displayed in WinFrog: 
.RML, .BSB, and .HDR. Each of these formats is a non-WinFrog-specific format.  
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To Load a New Working Chart (.RML/.BSB/.HDR) File 
1 From the File menu, choose Select Working Files. 

2 Select the Charts (*.RML) radio button. 

At the bottom of the Working Files dialog box, WinFrog displays the name of the current 
Working Chart (.RML) File in the File field and the file’s path in the Directory field. 

3 Enter the desired directory path into the Directory input field and the desired file name into 
the File input field.  

Note: the file and directory must already exist, a WinFrog will not create a new directory or 
a new working file. 

 Or alternatively, click the Browse button, navigate to the desired directory, select the 
desired file from the files listed in the Working File dialog box and then click Open.  

4 Click OK. 

To View the Working Chart (.RML/.BSB/.HDR) File 
After a Chart File has been specified as the Working Chart File, it can be viewed in 
WinFrog’s Graphics and Bird’s Eye displays. See the Operator Display Windows chapter for 
details on configuring WinFrog to display a chart. 

Working CRDD Database (.MDB) File 
The Working CRDD (.MDB) file contains data pertaining to Fugro Pelagos, Inc.’s Cable 
Route Design Database (CRDD). This database is created using the CRDD software and 
loaded into WinFrog for use with WinFrog’s real time cable lay modeling utilities. 

The CRDD database, as loaded into WinFrog, typically contains only pre-lay “plan” cable lay 
information such as the Route Position List (RPL), the location of cable bodies, and the 
amount of cable slack that will be laid in the various sections of the cable route. 

During the cable installation, WinFrog updates this database with actual “as-laid” cable data 
such as cable body locations and cable counts. This provides the on-board cable engineers the 
ability to analyze in near real-time how well the cable installation is matching the proposed 
installation plan and, subsequently, adapt the installation as required. 

To Load a New CRDD Database (.MDB) File 
Although WinFrog’s File > Select Working Files menu lists the CRDD Database File as an 
option, this dialog window cannot be used to load a .MDB file. 

1 Select the main menu item File > Cable Database > Open Database. The Cable 
Engineering Database dialog window appears, as seen below. 
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2 Enter the name and location of the database file or select the Browse button to navigate to 
the desired file. 

3 Select OK to confirm the entry and close this window. 

At the bottom of the Working Files (File > Select Working Files) dialog box, WinFrog 
now displays the name of the Working CRDD (.MDB) file in the File field, and the file’s 
path in the Directory field. 

To Edit the Working CRDD (.MDB) File 
Once a CRDD File has been loaded, its contents can be viewed and edited. See the WinFrog 
Cable Management Extension Module (WCMEM) and Cable Route Design Database 
(CRDD) User’s Guide for more information. The .MDB file can also be used to generate a 
survey line in the Working Survey Line file.  

Working Transponders (.XPT) File 
The Working Transponders (also referred to as Xponders) file is used to maintain the 
position data and transponder specific attributes associated with either Long Baseline (LBL) or 
Ultra Short Baseline (USBL) subsea transponder stations. In the case of Fixed transponders, 
this approach allows for the support of the stations in a similar manner as taken to land control 
networks, including occupancy and re-occupancy of any given station by multiple transponders, 
either simultaneous or non-simultaneous. In the case of non-Fixed transponders, this approach 
does not affect the configuration or use of these except to enhance the configuration of the 
Fixed stations to measure to. The reader is referred the LBL Operation, USBL Operation and 
Acoustic Calibration chapters for details. 

Multiple Xponders files may be created, saved and edited. However, only one can be set to be 
the Working Xponders file at any one time. 

A Working Xponders file is required for all LBL and selected USBL operations. 

In the context of WinFrog, the term transponders refers to subsea hardware devices that receive 
an impulse, either electronically or acoustically, that triggers them to transmit an acoustic pulse 
in return. Ranges are derived by analyzing the time it takes for the sound to travel (round trip) 
and knowing the speed of sound in water. In addition, some transponders are what are known as 
smart transponders. These are capable of performing operations other than simply responding 
to a signal, such as measuring to other transponders, reading internal sensors providing depth 
and attitude data and/or executing a sequence of pre-loaded commands. Smart transponders can 
usually be operated in more than one mode. 
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In the case of LBL acoustics, the transponders in the Xponders file generally include a network 
array of static Fixed transponders located on the seafloor or nearby structures at known 
coordinates. If these transponders are to be ranged to using transceivers connected directly to an 
LBL control unit, these are the only transponders required in the file. If transponders are to be 
used on static structures that require final position determinations or moving vehicles or 
structures that are to be tracked, they must also be included in the Xponders file. 

In the case of USBL acoustics, the transponders in the Xponder file are generally static Fixed 
transponders (or other) which are used for the calibration of the USBL system. These Fixed 
units can also be used to position the vessel with the USBL system. USBL transponders can 
also be used in similar situations as LBL transponders to track and position subsea vehicles and 
structures. In this case, it is not currently necessary to include these in the Xponders file, but it 
is recommended. WinFrog currently utilizes the information for these tracking transponders if it 
is available in the Xponders file and future development will require it. 

Transponders contained in the Working Xponders file can be displayed in WinFrog’s 
Graphics and Bird’s Eye window. See the Operator Display Windows chapter for more 
information about WinFrog graphics displays. 

Note: Prior to performing any LBL acoustic calibrations or positioning, a Working Xponders 
(.XPT) file and a Working Velocity (.VEL) file must be created. 

Note: Prior to performing a USBL calibration, a Working Xponders (.XPT) file must be 
created. A Working Xponder (.XPT) file is not required for USBL tracking of beacons, but is 
required if a beacon is fixed for use in tracking the USBL transceiver. 

Overview of the Working Xponders Types 
Transponders with varying capabilities are available from several manufacturers. The following 
is a list of the available transponder types and/or operational modes that WinFrog supports and 
an example of their application. It should be noted that in many cases, the same transponder can 
be used for any one of the modes simply by configuring it accordingly. Details on the 
configuration for each is given in Editing Xponders. The list mirrors the options available in 
the aforementioned section. 

LBL 
 Fixed 
The transponder is static and is generally part of a network array of other Fixed 
transponders. It is measured to by a transceiver or a smart transponder, providing range 
data. The resulting observations are used in a Least Squares Adjustment to solve for the 
position of the transceiver or smart transponder. The Fixed transponders form the basis 
of almost all LBL acoustic positioning. The positions of the Fixed transponders are 
determined with an LBL Calibration (see Chapter 20: LBL & USBL Calibrations). 
These positions are then used as known data in associated adjustments. 

 Relay 
The Relay transponder is dynamic, usually mounted on an ROV. It is used for positioning 
in Relay, or sing-around mode and requires an array of Fixed transponders. An LBL 
control unit and its transceiver are usually located on a surface vessel. This control unit 
transmits a signal to the Relay transponder on a unique frequency. The Relay transponder 
then transmits a common interrogation signal. This signal is received by the originating 
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transceiver. In addition, this signal is also received by the Fixed transponders in the array 
which each then transmit their own signals which are received by the aforementioned 
transceiver. A subsequent direct interrogation of the Fixed transponders by the transceiver 
completes the data collection cycle. By combining the observations, WinFrog derives the 
ranges from the Fixed transponders to the Relay transponder in addition to the range from 
the control unit’s transceiver to the Relay transponder. This data is then used in a Least 
Squares Adjustment to solve for the position of the Relay transponder. 

 Responder 
This is a special case of transponder. It is a transmit-only unit that is connected directly to a 
control unit via a cable. The control unit and its transceiver are usually located on a surface 
vessel. The Responder is used in the same way Relay transponder except that instead of 
receiving a signal from the control unit’s transceiver acoustically, it receives it directly 
electronically via the cable. The Responder is usually located on an ROV and is connected 
to the control unit via the ROV’s umbilical. 

 Simultaneous 
This is a smart transponder capable of performing its own range interrogation of other 
transponders (usually Fixed) when instructed to do so by the control unit via an acoustic 
trigger. The observed data is then acoustically telemetered to the control unit where they 
can be used in a Least Squares Adjustment to solve for the position of the smart 
transponder. Simultaneous transponders are usually mounted on ROVs and structures 
being placed or monitored on the seafloor. 

 Cyclic 
This is a smart transponder capable of being programmed with a series of measurement 
commands. Then on a trigger from the control unit, the series of commands is executed and 
the results are telemetered to the control unit for use in a Least Squares Adjustment to solve 
for the position of the Cyclic transponder. A Cyclic transponder is used for low dynamic 
situations such as the final positioning of a structure in acoustically noisy conditions. 

 Sequential 
This is a smart transponder capable of measuring baselines to specified Fixed 
transponders. WinFrog instructs the Sequential transponder to execute baseline 
measurements, sequencing through a list of specified Fixed transponders. The results are 
used in a continuous Least Squares Adjustment of the Sequential transponder position. 
That is, as new baseline data is observed, it replaces old data for the same baseline and a 
new position is determined using all baseline data currently available. The Sequential 
transponder is used for lower dynamic situations such as the final positioning of a structure 
in acoustically noisy conditions. 

 Static Transceiver 
This is a standard control unit transceiver. However, whereas the control unit transceiver is 
generally dynamic, attached to a moving vessel and therefore not included in the Working 
Xponder File, this is a special case where the transceiver is static, attached to a fixed 
structure or simply on the seafloor. The Static Transceiver is used to range to a dynamic 
array of transponders. The observations are combined with observations from other Static 
Transceiver units or Static Simultaneous units in a Least Squares Adjustment of the 
position of the dynamic transponders. In addition, WinFrog can also be configured to 
perform a subsequent Least Squares Adjustment for the attitude and orientation of the 
dynamic transponders. (See Static Simultaneous and Dynamic Array.) This is used for 
monitoring the movement of a dynamic structure. 
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 Static Simultaneous 
This is a smart transponder capable of operating as a Simultaneous transponder. 
However, like the Static Transceiver whereas a Simultaneous transponder is generally 
dynamic, attached to a moving vehicle, this is a special case where the transponder is static, 
attached to a fixed structure or simply on the seafloor. The Static Simultaneous is used to 
range to a dynamic array of transponders. The observations are combined with observations 
from other Static Simultaneous units or Static Transceiver units in a Least Squares 
Adjustment of the position of the dynamic transponders. In addition, WinFrog can also be 
configured to perform a subsequent Least Squares Adjustment for the attitude and 
orientation of the dynamic transponders. (See Static Transceiver and Dynamic Array.) 

 Dynamic Array 
This is a Fixed transponder mounted on a moving vehicle or structure. It is required for use 
with the Static Transceiver and Static Simultaneous units. In addition, it can be part of a 
network array of Dynamic Array transponders on the moving structure that have been 
precisely surveyed prior to deployment. This provides precise baselines for each Dynamic 
Array transponder pair. These baselines are constrained in the Least Squares Adjustment 
using the observations from the associated Static Transceiver and Static Simultaneous 
units for the positions of the Dynamic Array transponders and subsequent Least Squares 
Adjustment for the attitude and orientation of the structure the Dynamic Array 
transponders are mounted on. 

 Synchronized Pinger 
This is a pinger that outputs a pulse at regular intervals. The beacon is synchronized with an 
atomic clock so that the epoch of the pulse is known. Thus the travel time from it to a 
passive hydrophone can be determined without actually triggering the beacon. 

USBL 
 Fixed 
This beacon is static. In most applications, it is deployed and used only for the calibration of 
the USBL hydrophone, although it can also be used to position a vessel with a USBL 
hydrophone mounted on it. 

 Tracking 
This beacon is dynamic, generally attached to an ROV or towed body. It is positioned from 
a vessel with a USBL hydrophone mounted on it. 

USBL Beacon Types 
 Transponder 

The beacon is an independent unit, that when interrogated with an acoustic signal, 
responds. 

 Pinger 
The beacon is an independent unit that transmits an acoustic signal at a 
predefined rate. 

 Responder 
The beacon is a unit linked to the USBL control unit by cable. It is interrogated 
with an electrical signal and responds with an acoustic signal. 
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Working with Xponders Files (*.XPT) 
Multiple Xponder files may be created, saved and edited. However, only one can be set to be 
the Working Xponders file at any one time. 

The Working Xponders (.XPT) file must be created (or selected) before data for information 
for a specific transponder can be added. 

Creating a New Xponders File 
The creation of an Xponders file is detailed in the Creating and Selecting Less Common 
Working Files section earlier in this chapter.  

In addition, the Xponders file can be created directly from the Acoustic Window via File\ 
New…>Xponder. 

 

In both cases, before the xponders file can be saved to disk, at least one xponder must be added 
(see To Add an Xponder to the Working Xponders File). WinFrog will then detect that the 
document has been altered and prompt you to save it. 

Opening an Xponders File 
The opening of an existing Xponders file is detailed in the Creating and Selecting Less 
Common Working Files section earlier in this chapter. Once open, the file can be edited or 
assigned as the Working Xponders file. Upon the completion of editing, WinFrog will detect 
that changes have been made and prompt you to save the file. 
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The Xponders file can be edited even if it is not set to be the Working Xponders file. The 
editing is performed as detailed in Editing the Working Xponders File below with the 
exception that the non Working Xponders file must be opened from the Main Menu File\ 
Open item. 

When an existing or Working Xponders file is opened, the name of the file will be displayed 
as the title for the dialog. 

Designating an Xponders File to be the Working Xponders File 
The designation of an Xponders file as the Working Xponders file is detailed in the Creating 
and Selecting Less Common Working Files section earlier in this chapter.  

In addition, the Xponders file can be set to be the Working Xponders file directly from the 
Acoustic Window via File\ Set to Working…>Xponders. This accesses a browse dialog 
allowing you to find and select the Xponders file to set to the Working Xponders file. When 
done this way, the file is not presented for editing but simply set to be the working file. 

Editing the Working Xponders File 
This section details the steps required to perform basic file operations. The specific details of 
editing the actual Xponder configuration is given Editing the Xponder section in this chapter. 

To Open the Working Xponders File 
1 From the main menu File item, choose Edit Working Files... > Xponders. The Working 

Xponders file will open. 

Or 

2 From the Acoustic Window File item, choose Edit…> Xponder. The Working Xponders 
file will open. Note the Working checkbox will be checked for the file that is currently set 
to be the Working Xponders file. 
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To Add a Transponder to the Working Xponders File 
1 Open the Working Xponders file. 

2 Click Add to bring up the Transponder/Beacon dialog. 

 

3 Configure the Xponder (see Editing Xponders) and click the OK button. WinFrog will 
check that a name has been entered and if not return you to the Transponder/Beacon 
dialog to correct this. 
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To Delete a Transponder from the Working Xponders File 
1 Open the Working Xponders file. 

2 Select those Xponders from the list that are to be deleted. Multiple Xponders can be 
selected by holding the Ctrl key while selecting the Xponders with the mouse. 

3 Click Delete to remove the selected Xponders from the list and file. 

To Edit a Transponder in the Working Xponders File 
1 Open the Working Xponders file. 

2 Click on the Xponder in the list to be edited and click the Edit button to bring up the 
Transponder/Beacon dialog. 

Or 

3 Double-click on the Xponder in the list to be edited to bring up the Transponder/Beacon dialog. 

4 Configure the Xponder (see Editing the Xponder) and click the OK button. WinFrog will 
check that a name has been entered and if not return you to the Transponder/Beacon 
dialog to correct this. 

Special Case: Double Occupancy 
WinFrog supports multiple transponders co-located on the same station. This addresses two 
main scenarios. The first is when transponders of different frequencies (generally MF and EHF) 
are placed at the same location to support surface ranging and baseline observations when EHF 
observations are required for optimum baseline accuracy, but the water depth is too great for the 
EHF to be interrogated from the surface. In this case, each transponder is added and edited 
accordingly and referenced to the same point, both horizontally and vertically. The latter is 
generally achieved using the Height of Instrument entry. The second scenario is when a 
transponder that supports both USBL and LBL operations is used, the USBL mode for surface 
ranges and the LBL mode for baseline observations. In this case an Xponder is created for each 
operation mode, again ensuring that they are both referenced to the same point horizontally and 
vertically. The vertical reference must be the transducer of the transponder. In both scenarios it 
is critical that the same name be entered for each Xponder entry. 

When WinFrog detects that a name used for an Xponder is the same as that used for another, it 
will report this and ask for confirmation that this is correct. If it is not, you are returned to the 
Xponder configuration dialog for the one just edited/added so that the name can be changed. 

To Configure the Fixed Transponder Networks 
Transponders in an Xponders file can be associated in groups or networks. Currently, this 
functionality is limited to the collection of calibration data. This grouping of the transponders 
allows WinFrog to be set to automatically determine all possible baselines between Fixed LBL 
transponders in a given network, initiate the measurements of these and log the results to the 
calibration data file. Similarly, WinFrog can be configured to automatically interrogate all the 
transponders in a given network for depth observations and log the results to the calibration data 
file.  

All Fixed LBL transponders default to be part of Net1. 
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1 Open the Working Xponders file. 

2 Click Networks to bring up the Transponder Networks dialog. 

 

The Transponder Networks dialog provides the following information and controls: 

Network list This lists the network the corresponding transponder is a 
member of. If you select a network in this list, the corresponding 
transponder in the Transponder list will be highlighted and the 
network will be displayed in the Network field. 

Transponder list This lists all the Fixed LBL transponders in the Working 
Xponders file. If you select a transponder in this list, the 
corresponding network in the Network list will be highlighted 
and the network will be displayed in the Network field. 

Network field This presents the network the currently selected transponder is 
a member of. It also allows you to change and add networks. 

Available Network list This is a drop down list of all the networks that existed when 
the dialog was opened plus those added during the current 
editing. 

Update button This allows you to apply changes made to the network 
association for the currently selected transponder, made 
either via the Network field or the Available Network list. 

 
3 To Change a Transponder’s Network to a New Network 

i Select the transponder in the Transponder list that is to be a member of the new 
network. 
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ii Enter the name of the new network in the Network field. 

iii Click the Update button. 

iv The name of the network as displayed for the edited transponder will be updated to 
the new network name. In addition, the new network name is added to the 
Available Network list. 

4 To Change a Transponder’s Network to a Existing Network 

i Select the transponder in the Transponder list that is to be changed to an existing 
network. 

ii From the Available Network list, select the desired network. 

or 

iii Enter the name of the existing network. 

iv Click the Update button. 

v The name of the network as displayed for the edited transponder will be updated to 
the new network name. 

5 Click OK to exit the Transponder Networks dialog and apply the changes to the Working 
Xponders file. 

Or 

6 Click Cancel to exit the Transponder Networks dialog and without apply the changes to 
the Working Xponders file.  

To Print the Transponder File 
1 Open the Working Xponders file. 

2 Click Print to bring up the Print Transponder File dialog. 

 

3 Select either Printer or To File option. Selecting Printer results in the print going directly 
to the Windows default printer. If selecting the To File option, you must either enter the 
target file or use the Browse button to locate or enter an appropriate file name. 

4 Click the OK button. This will exit this dialog and execute the appropriate printing. When 
the printing is completed, you will be informed with a message box stating Writing to File 
Finished. 
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To View the Transponder File Summary 
WinFrog provides an Xponders File summary window where the information for all 
transponders in the file can be viewed together. The information is presented in a tab format in 
resizable window, complete with scroll bars as required. 

Clicking on selected column headers will result in the information being sorted based upon the 
information in that column. 

A transponder can be edited by double clicking the name. The Transponder/Beacon dialog 
appears. You must be careful as multiple Transponder/Beacon dialog boxes can be opened in 
this manner, even for the same transponder. 

1 Open the Working Xponders file. 

2 Click Summary to bring up the Transponder Summary window. 

 

3 The first tab presented is the Position tab, presenting in the following columns: 

Xponder The name of the transponder station (supports sorting). 

Address The address of the transponder station (supports sorting). 

Northing The Map Projection Grid Northing of the transponder station. 

Easting The Map Projection Grid Easting of the transponder station. 

Latitude The Working Ellipsoid latitude of the transponder station. 

Longitude The Working Ellipsoid longitude of the transponder station. 

Depth The depth of the transponder station. 

Instrument Ht. The height above the station the transponder’s transducer is. 

Type The LBL Mode/Type and/or USBL Mode setting of the transponder 
station (supports sorting). 

Model The manufacturer model of the transponder station (supports sorting). 

4 Clicking the Control tab shows the following information: 
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Xponder The name of the transponder station (supports sorting). 

Address The address of the transponder station (supports sorting). 

Network The name of network the transponder is assigned to. 

Tx Code The frequency or corresponding channel the transponder is set to reply 
to common interrogations on (supports sorting). 

Rx Code The frequency or corresponding command the transponder is expecting 
to receive (supports sorting). 

Rng Corr The correction to the TWTT un-accounted for by the LBL acoustic 
control unit to be applied by WinFrog. 

Bcn Code The USBL transponder identifier (supports sorting). 

5 Clicking the Status tab shows the following information. This is specifically designed to 
support Sonardyne hardware. 

Xponder The name of the transponder station (supports sorting). 

Address The address of the transponder station (supports sorting). 

Firm Ver. The firmware version number of the transponder. 

Enabled The operation mode/status of the transponder (supports sorting). 

Reply Chan The channel the transponder will reply to an Individual Interrogation 
Frequency (IIF) interrogation. 

Int Wait The length of time in milliseconds the transponder is configured to wait 
between receiving an interrogation command and interrogating the 
specified transponder. 

Reply Wait The length of time in milliseconds the transponder is configured to wait 
for a response to its interrogation command. 

Tel Wait The length of time in milliseconds the transponder is configured to wait 
between commands when operating in Cyclic mode and between 
telemetry bursts when operating in Simultaneous mode. 

Battery The type of battery installed in the transponder. 

Time The time of the last Status update. 
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Editing Xponders 
The editing and configuring of transponders is done from the Transponder/Beacon dialog. The 
options available depend upon the transponder model and application mode. Those options that are 
not applicable for the current model and application mode are disabled to eliminate confusion. 

In addition, there are two distinct configuration option sets, one for what is considered standard 
application mode, and another for non- standard application mode. Non-standard mode are 
Static Transceiver, Static Simultaneous and Dynamic Array. All others are considered to be 
standard. This section looks at each individually. 

For standard Fixed applications, the concept of a survey station is applied in that the station is 
defined in the Xponder file plus the transponder that is mounted at that station. That is, the Name, 
Depth of Monument and Position information refer to the station independently of the transponder 
itself. The occupying transponder is referenced to the station by the Height of Transducer Above 
Monument information. This supports the simultaneous occupancy of one station by multiple 
transponders. It also facilitates the use of mounting buckets for holding transponders in a semi-
permanent array. The transponder is assumed to be mounted vertically over the station. In the case 
of a non-vertical deployment, the station Depth of Monument and Position should be related to 
the transponders transducer and the Height of Transducer Above Monument be set to 0. 

WinFrog identifies Fixed transponders by station Name and Address. 

Editing Standard Xponders 
The following details the configuration options for standard application mode transponders. 
Please refer to Overview of the Working Xponders Types for a description of each 
application mode to decide which is required. 
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Name/Position 
Name field Enter a unique name for the station. Stations can have more than 

one transponder assigned to them. If more than one transponder 
is located at the same station, whether simultaneously or not, 
each must have an Xponder (station) added to the file with the 
same name used for both. Transponders are differentiated by 
WinFrog using the (station) Name and transponder Address. 

Depth of 
Monument field If this is an LBL Fixed or USBL Fixed transponder application, 

then this value is the depth of the station, that is some point on 
the seafloor that will remain constant regardless of what 
transponder is deployed over it. If the transponder is not 
deployed vertically over the station, this should be set to the 
depth of the transducer. 

Height of transducer 
above Monument 
field If this is an LBL Fixed or USBL Fixed transponder application, 

then this value is the distance from the station to Monument to 
the transponder’s transducer, also referred to as a Height of 
Instrument or HI. If the transponder is not deployed vertically 
over the station, this should be set to 0. 

Position field If this is an LBL Fixed or USBL Fixed transponder application, 
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enter the coordinates of the station the transponder is located 
over. If the transponder is not deployed vertically over the 
station, this should be set to the position of the transducer. 

  The coordinates can be either entered in the Working Ellipsoid 
geographic latitude and longitude or in the currently selected 
Map Projection grid coordinates, Northing and Easting. 

Depth Sensor 
button This accesses a Depth Sensor Information dialog. This allows 

you to enter the data required to relate the depth sensor to the 
transponder’s transducer. 

 

 

Depth Sensor Offset  This is the vertical offset from the transponder’s 
transducer to the depth sensor. This value is 
automatically set based on the transponder 
model selected, but may be changed to suit the 
actual conditions. It must be modified in cases 
where the transponder is not mounted vertically 
with the transducer on the top. 

 Note: The sign convention to use is as follows: 
if the transducer is above the depth sensor, this 
value is a negative number; if the transducer is 
below the depth sensor, this value is a positive 
number. 

Depth Sensor Calibration This field is for entry of the depth sensor 
calibration value for that particular sensor. To 
obtain this value, observe the sensor’s apparent 
depth while the transponder is on the deck. Enter 
the observed value here, keeping the same sign. 

  

Type 
Model button This opens the LBL Xponder Model dialog box, as seen below. 

Note that the model selection impacts the transponder 
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configuration options. Selecting MK3 or MK4 Compatts causes 
the LBL Mode Responder radio button to disable, as this is not 
supported for the PAN device. It also causes the Extended 
Status button to become active as this is only supported for the 
Sonardyne transponders. Additionally, the Control Parameter 
edit boxes become dropdown boxes with preset values for 
Sonardyne transponders. 

 

Generic The default setting is Generic. This is the setting 
for all LBL and USBL transponders except for 
those listed below. 

MK3 Compatt This is a specific Sonardyne smart transponder 
model used with the Sonardyne PAN or 
ROVNAV device. Setting this enables WinFrog 
to provide extended functionality, including 
Extended Status monitoring. 

MK4 Compatt This is a specific Sonardyne smart transponder 
model used with the Sonardyne PAN or 
ROVNAV device. Setting this enables WinFrog 
to provide extended functionality, including 
Extended Status monitoring.  

 Note: Select this model for the MK 5 
COMPATTs also. 

Kongsberg Simrad (400) This is a specific Kongsberg Simrad USBL 
beacon (or similar if it emulates the same) that is 
used primarily with the HPR 400 systems and 
APOS software. The associated beacon codes 
are not simple integers. Selection of this type 
instructs WinFrog to accept entry and display of 
the USBL beacon code in the native format (e.g. 
B61). 

SEAFAC This is a specific type of acoustic equipment 
using passive hydrophones and synchronized 
pingers. 

LBL Mode radio buttons 
Select one of the following if the transponder is for LBL use. For more information 
regarding each option, see Overview of the Working Xponders Types at the beginning 
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of this chapter. For information concerning their use, see the LBL Acoustic chapter. 

Fixed This is a static transponder located at a known point. A group 
of these form a network array(s) that provide the basis for all 
the standard LBL applications. 

Relay This is generally a mobile transponder, normally attached to a 
subsea vehicle. It is interrogated acoustically by a ship-based 
transceiver/control unit. 

Responder This is generally a mobile transponder, normally attached to a 
subsea vehicle, that is actually attached to the LBL control unit 
via a cable and triggered electronically.  

Simultaneous This is generally a mobile transponder, normally attached to a 
subsea vehicle, that upon being triggered acoustically by a 
transceiver attached to a control unit, performs measurements 
to other transponders and transmits the data acoustically to the 
originating transceiver. 

Cyclic This is generally a mobile transponder (low dynamics), 
normally attached to a subsea vehicle, that upon triggering 
acoustically by a transceiver attached to a control unit, executes 
a series of preprogrammed commands. 

Sequential This is generally a mobile transponder (low dynamics), 
normally attached to a subsea vehicle. If an XPONDER data 
type is attached to a vehicle, WinFrog automatically sequences 
through a list of Fixed transponders commanding this 
Sequential transponder to measure the baseline to each one in 
turn. 

Static Transceiver See Editing Non-Standard Xponders. 
Static 
Simultaneous See Editing Non-Standard Xponders. 
Dynamic Array See Editing Non-Standard Xponders. 
 
Synchronized Pinger This is disabled unless the SEAFAC model is selected. Select 

this mode to describe the pinger mounted on the vehicle to be 
positioned. 

 

USBL radio buttons 
The configuration for the USBL transponders is broken into two parts, Mode and Type. 

Note: The term transponders is used here as a general term for USBL systems. As seen 
below, there are actually different types. In addition, the units are often referred to as 
beacons.  

USBL Mode 

The Mode refers to how the transponder used. 

Note: WinFrog currently bases some optional timing control for positioning a tracked 
beacon upon data entered in the Working Xponders file for the tracked beacon. If the 
tracked transponder is not entered in the Working Xponders file, WinFrog will assume 
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it is a transponder. 

Fixed The transponder is static at a known location and used for 
positioning the hydrophone vehicle, or for a USBL Calibration. 

Tracking The transponder is attached to a moving vehicle, generally an 
ROV or towed body, whose position is being tracked from the 
USBL hydrophone vehicle. 

USBL Type 

The Type refers to the actual operating type of beacon. 

Pinger This unit transmits a signal at a set frequency and rate, it is not 
interrogated by the USBL system. 

Transponder This unit is acoustically interrogated by the USBL system and 
replies. 

Responder Like the Responder for the LBL acoustics, this unit is connected 
to the USBL system via a cable. It is electronically interrogated 
by the USBL system and replies with an acoustic signal. 

Control Parameters 
LBL group 
Transmit field Enter the transmit frequency or code of the LBL transponder. If 

the LBL equipment uses actual frequencies rather than a code or 
a channel, then the frequencies must be entered with a decimal 
point and all significant digits, including zeros. Essentially, what 
is entered here must match the data string coming from the 
instrument. In the case of Benthos, the information associated 
with the transponder transmitting at 14kHz will have 14.00 in the 
message coming from the instrument. (i.e. for Benthos xponders, 
14 kHz must be entered as 14.00). 

 If the LBL equipment uses codes or channels rather than actual 
frequencies, then enter the appropriate code or channel (i.e. 
Common Interrogate Frequency should be entered as CIF, and 
channel 3 should be entered as 3). 

 A Fixed transponder’s transmit frequency (channel) will 
normally be the transponder’s Output frequency (i.e. 14.0 
or 3). 

 A Relay transponder or Responder’s Transmit 
frequency/channel will normally be the Fixed transponder’s 
Receive frequency (i.e. 11.50 or CIF). 

Receive field Enter the LBL transponder’s Receive frequency or code. If the 
LBL equipment uses actual frequencies rather than code or 
channel, then the frequencies must be entered with a decimal 
point and all necessary significant digits including zeros. (i.e. 
11.5 kHz should be entered as 11.50). The value entered here 
must match the data string coming back from the instrument. In 
the case of Benthos, the information associated with the 
transponder receiving at 11.5kHz will have 11.50 in the message 
coming from the instrument.  

 If the LBL equipment uses code or channel rather than actual 
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frequencies, enter the code or channel (i.e. Common 
Interrogate Frequency should be entered as CIF, and 
Simultaneous interrogation is selected as SI or FS). 

 A Fixed transponder’s receive frequency or channel will 
normally be the transceiver’s (or relay transponder’s) 
transmit frequency (i.e. 11.50 or CIF).  

 A Relay transponder’s receive frequency or 
command/channel will normally be the transceiver’s transmit 
frequency (i.e. 9.0 or RY1). 

 A Responder, although triggered by a physical connection (i.e. a 
wire), still requires a receive frequency/channel to be entered to 
match the configuration of the acoustic hardware. 

Address field Enter the transponder address. This is only applicable to MK-III 
and MK-IV Compatts. 

 Note: Do not enter an address for transponders that do not use 
addresses. Also ensure there are no blanks present in any entries 
made. 

Range Correction to be  
subtracted by 
WinFrog field This entry is that portion of the transponder’s turn-around-time 

(TAT) that is not accounted for by the LBL control unit. It is 
subtracted from the two-way-travel-time (TWTT) for this 
transponder received by WinFrog. This entry is not the value 
actually subtracted by the acoustic electronics before a range is 
sent to WinFrog. 

USBL group 
Code field Enter the code of the USBL beacon. If the USBL device is a 

Kongsberg Simrad HPR 400 (see Type above), enter the HPR 
beacon code (e.g. B61). 

 

Supporting Configuration Options: Sensor Setup Button 
To access the extended sensor configuration options available for Sonardyne MK-III and 
MK-IV Compatt transponders click the Sensor Setup button. Note that only one sensor 
can be available in one transponder due to space constraints. 
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Depth Sensor Select the depth sensor type installed in the 

transponder, either Digiquartz or Strain Gauge 
(default). 

Digiquartz Cal Pars 
button This accesses the Digiquartz Calibration 

Coefficients dialog. 
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Coefficients Enter the coefficients directly from the 
digiquartz coefficient sheet provided with a 
digiquartz equipped transponder. 

Depth Calculation 
Method Select either the UNESCO formula or average 

density. If the average density is selected then 
enter the density to use in the edit box. The 
formula used to convert the pressure to depth is  
D = (pressure-atmosphere pressure)/density 
If the UNESCO formula is selected, enter the 
latitude of the work area in the edit box. The 
UNESCO formula is described by Fofonoff N.P. 
and Millard R.C. Algorithms for computation of 
fundamental properties of seawater UNESCO 
technical papers in marine science No 44 (1983). 

Water Density Enter the average water density for the water 
column in kilograms per metre3. 

Latitude Enter the latitude of the work area in degrees. 
Atmospheric Pressure Enter the ambient atmospheric pressure in 

millibars.  
Depth Rating Select the appropriate rating for the digiquartz 

sensor. 
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(COMPATT Sensors dialog box) 

Digiquartz Temperature count 
LBL Device for TQ If interrogating the transponder for a 

temperature count, select the LBL Device to use 
to obtain the initial count. 

Initial Temp Count Clicking this button will cause WinFrog to 
interrogate the transponder for a Temperature 
Count value. The response is automatically 
associated with this transponder for subsequent 
digiquartz value interrogations (DQ commands). 

Other Sensors 
Select any other sensor that is installed in the transponder. 
None There is no other sensor available. 
Internal Inclinometer There is an internal inclinometer installed in the 

transponder. This enables use of the 
ATTITUDE data item with the transponder. 

External Inclinometer There is an external inclinometer installed in the 
transponder. This enables use of the 
ATTITUDE data item with the transponder. 

Inclinometer Corrections Enter calibration values for this inclinometer. 
The values entered here are saved with this 
transponder in the *.XPT file, but not applied 
directly from here. However, they may be 
accessed from this transponder from the 
ATTITUDE data item when edited, after 
assigning to a vehicle. 

Inclinometer Calibration 
button The corrections may be determined by 

performing a calibration. Click this button to 
perform an inclinometer calibration. An LBL 
device must already be available to perform the 
calibration, as readings of the inclinometer are 
required. See below. 

Conductivity Future development. 
Cel Cal Pars Future development. 

 

Inclinometer Factor 
The inclinometer factor is used to convert the observed analog value (volts) to an 
angle. The factor depends upon the range of the instrument and the COMPATT. 
Several preset values can be obtained by selecting the COMPATT model and 
range. If none of these options are correct for this COMPATT and inclinometer, a 
manual factor may be entered. WinFrog uses the following formula to convert the 
voltage to an angle: 
Angle = sin-1(voltage/factor) 
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Inclinometer Calibration 
When you click the Inclinometer Calibration button the following dialog opens: 

 

This dialog is used to obtain pitch and roll readings of a transponder that can be 
compared to known values in order to estimate a calibration or correction factor. 
Note: When performing this calibration you should stop all other interrogation 
activity. 

Device 
Device Select the device to use to interrogate the 

transponder. 

Parameters 
Interrogation Interval Enter the time interval between interrogations in 

seconds. 
Number of interrogations Enter the total number of observations. 

Information 
Points in memory This is the current number of pitch and roll 
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observation in memory. 
Clear This button clears all the points currently in 

memory. All of this data will be lost so be sure 
to save it first. 

Blank Area When a telegram is received from the device in 
response to a command it will be displayed here. 

Mode Indicates if the device is being interrogated or 
not. 

File File name of the data. 

Controls 
Make Observations Click to start the observation process. If other 

interrogations are taking place these 
observations will be queued. 

Stop Stops the observations if they have not finished. 
Process Data When the desired amount of data has been 

obtained and interrogation has ceased, click this 
button to compute the calibration values. A 
dialog box will appear, see below. 

Save and Load These buttons allow the data to be saved in an 
ASCII text file or loaded from such a file. The 
default file type is *.ATT 

Apply Values 
 After the data has been processed, this button 

will become active. Click this button to copy the 
corrections to the COMPATT Sensors dialog. 
Note: it does not apply them to observations for 
the ATTITUDE data item. You must edit this 
data item and enter the values manually or select 
these values by selecting this COMPATT from 
the dropdown list of COMPATTS. 

Processing the Inclinometer Data 
1 After the data has been obtained, click the Process Data button to obtain the 

following dialog box: 
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The dialog opens with the data set already processed. Displayed is the mean, 
standard deviation and residuals of the pitch and roll data set. Corrections are 
also determined based on default actual pitch and roll values of zero. 

The “Error” indicator in the Values list box is the error code received from 
the LBL device. 

To reject an observation set, highlight it in the Value list box and click the 
Toggle Include/Exclude button. Although the observation of pitch and roll of 
this record will no longer be used to calculate the mean and standard 
deviation, the difference between the mean and the observation will be 
displayed under the Res heading. 

If the default “Actual Pitch and Roll” of zero is incorrect, enter the actual 
pitch and roll of the transponder while the observations were taken. 

When all the desired changes have been made, click the Re-Calculate button. 

Click Done to close the box and carry the corrections back to the previous 
dialog where the Apply button will become active. 

Supporting Configuration Options: Cyclic Setup Button 
To access the Cyclic setup dialog, click the Cyclic Setup button. To enable the cyclic 
transponder mode the transponder address must be entered, the model must be set to 
either a Mk III or Mk IV COMPATT and the LBL Mode must be set to “Cyclic”. 
(Note: if the address is entered last the focus must be changed from the address edit box 
before the “Cyclic” button will enable.) Since setting up a COMPATT for cyclic 
operation requires communication with the COMPATT, either a PAN or ROVNAV 
device must be added to WinFrog before the cyclic setup can be accomplished. In 
addition, the Xponders file must be the current Working Xponders file. If either of 
these conditions have not been satisfied when the cyclic button is clicked a message box 
will appear informing you of the lack of communications. 
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The dialog box presents only those commands available for loading to the transponder’s 
memory. This dialog also acts as a terminal to communicate with the COMPATT via 
the PAN or ROVNAV. Each command is a two part operation; a) select the desired 
command which will then appear in the “Command to send…” box, where it can be 
edited, then b) push the “Send Command” button and wait for the response before 
closing. 

Initially WinFrog does not know which commands are stored in the COMPATT’s table, 
thus it is recommended that the list be cleared before continuing. First select the device 
from the “LBL Device” drop down list box, ignore the numbers after the device’s name. 
Then click the Clear list (DISABLE) button and send the COMPATT disable 
command. Once the device responds the cyclic command list will clear. Then select and 
send the desired commands. To send a sequential command (CI) first select the target 
channel, only those currently in the transponder file will appear the list. Once all the 
desired commands have been sent click on the Finish button to send the Terminate 
Cycle (TC) command. This will prevent additional commands from being placed in the 
table until the next time the Clear list (DISABLE) is clicked. Older COMPATT’s may 
not support the TC command, thus additional commands to this COMPATT will enter 
the table. The reader is referred to the Sonardyne documentation. 

Supporting Configuration Options: Save Button 
Click the Save button to force the saving of this transponder configuration to the 
Xponders file on disk. Note that this effectively accepts the configuration changes and 
therefore the OK button is disabled and the Cancel button is changed to a Done button. 
Click the Done button to exit the dialog. 

Supporting Configuration Options: Extended Status Button 
To view the status and configuration of this transponder, click the Extended Status 
button. This is specifically for the Sonardyne MK-III and MK-IV Compatts. You 
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must interrogate the transponder using the TS, BC and PS commands via one of 
WinFrog’s acoustic Terminal Windows. See in the Operators Display Windows 
chapter. 

 

Note:  It is important to note that if a transponder’s IRF is changed, the TS must be 
executed so that WinFrog can note the new IRF to use in its commands. 

Note:  The Sonardyne Dual Band Compatts must be treated carefully since the status 
they return when interrogated depends upon the mode they are operating in, i.e. either 
the EHF status or the MF status. WinFrog currently only supports a single status 
configuration for each transponder station and therefore cannot maintain the status for 
both frequencies, nor does it differentiate between the two. As a result, if the operator is 
not careful, the status information displayed may actually reflect a bit of each 
frequency. 

The time of the latest interrogation with the TS or BC command is given. 

To print the extended status for the transponder, click the Print button. 

Refer to Sonardyne’s technical manual for an explanation of the status information. 

To Print The Transponder Configuration 
1 To print this transponder, click the Print button. 
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2 Select either Printer or To File option. Selecting Printer results in the print going 
directly to the Windows default printer. If selecting the To File option, you must either 
enter the target file or use the Browse button to locate or enter an appropriate file name. 

3 Click the OK button. This will exit this dialog and execute the appropriate printing. 
When the printing is completed, you will be informed with a message box stating 
Writing to File Finished. 

Completing the Configuration 
Click the OK button to exit and keep the configuration changes or Cancel to exit and 
discard the configuration changes made. WinFrog checks for a valid transponder/station 
name. If one is not detected you are so informed and returned to the 
Transponder/Beacon dialog. 

Editing Non-Standard Xponders 
The following details the configuration options for non-standard application mode transponders. 
These non-standard applications involve fixed LBL Transceivers and Simultaneous 
COMPATTS and the moving transponders arrays, that is, the inverse of the standard 
application. Please refer to Overview of the Working Xponders Types for a description of 
each application mode to decide which is required. 

The following details the configuration options for each specific LBL Mode/Type option 
associated with this application, that is, the Static Transceiver, Static Simultaneous and 
Dynamic Array settings.  

Note: The Model, Save, Extended Status and Print buttons use is the same as that for standard 
applications. They are enabled and disabled accordingly. 

Configuring the Static Transceiver 
The Static Transceiver refers to a Sonardyne transceiver connected to either a PAN or ROVNAV 
MkIV and located at a known fixed point. The configuration of this unit within the Xponder file 
is independent of the actual device interface. The configuration options for this mode option are 
shown in the following figure. 

You are prompted for the information that will enable WinFrog to determine the position of the 
Static Transceiver’s actual transducer. A Static Transceiver will most likely be associated with a 
structure and /or vehicle and thus the configuration reflects this. However, it is important to note 
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that the application is not restricted to this and any position can be entered for the Static 
Transceiver. The data entry options are as follows: 

 

Name/Position 
Name Entry of the name by which the transceiver is to be 

known (maximum 24 characters). 
CRP Position The position of the CRP of the structure to which the 

transceiver is attached. If the transceiver is not attached to 
a specific structure, the known position of the transceiver’s 
transducer is entered. The coordinate entry is in either Grid 
or Geographic coordinates depending upon which of the 
Geo or Grid radio buttons is selected. 

Depth The depth of the CRP of the structure to which the 
transceiver is attached. If the transceiver is not attached 
to a specific structure, the known depth of the 
transceiver’s transducer is entered. 

Orientation The orientation of the structure to which the 
transceiver is attached. This is entered in either Grid or 
True depending upon which of the Geo or Grid radio 
buttons is selected. If the transceiver is not attached to 
a specific structure, the position and depth entered is 
for the transceiver’s transducer and therefore the 
orientation is not required and can be left at 0. 
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Pitch The pitch of the structure to which the transceiver is 
attached. If the transceiver is not attached to a specific 
structure, the position and depth entered is for the 
transceiver’s transducer and therefore the pitch is not 
required and can be left at 0. Note that the sign 
convention is bow up, pitch is positive. 

Roll The roll of the structure to which the transceiver is 
attached. If the transceiver is not attached to a specific 
structure, the position and depth entered is for the 
transceiver’s transducer and the roll is not required and 
can be left at 0. Note that the sign convention is 
starboard down, roll is positive. 

F/A Offset The foreward/aft offset from the structure’s CRP to the 
transceiver’s transducer. Foreward is positive, aft is 
negative. If the transceiver is not attached to a specific 
structure, the position of the transceiver’s transducer is 
located at is entered and this offset is left at 0. 

P/S Offset The port/starboard offset from the structure’s CRP to 
the actual transceiver’s transducer. Starboard is 
positive, port is negative. If the transceiver is not 
attached to a specific structure, the position of the 
transceiver’s transducer is located at is entered and this 
offset is left at 0. 

U/D Offset The up/down offset from the structure’s CRP to the 
actual transceiver’s transducer. Up is positive, down is 
negative. If the transceiver is not attached to a specific 
structure, the position of the transceiver’s transducer is 
entered and this offset is left at 0. 

Apply Projection Line 
Scale Factor This allows you to apply scaling of offsets to the Map 

Projection before being applied to the CRP position to 
determine the transducer position. In addition, the 
INVERTED LBL data types that use this Xponder will 
check this setting and if it is set, all observations will 
be scaled to the Map Projection before being used. If 
this option is not set, the observations are not scaled 
and the resulting positioning is truly relative. The 
default and normal mode would for this not to be set. 

 
When the above data is entered, WinFrog automatically uses the CRP position and 
depth, orientation, attitude (pitch and roll) and offsets to compute the position and depth 
for the Static Transceiver’s transducer. This data is displayed in the bottom of this 
panel. The position is displayed in either Grid or geographic coordinates depending 
upon which of the Geo or Grid radio buttons is selected. 

No other options or operator I/O is available for this mode. 
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Configuring the Static Simultaneous 
The Static Simultaneous (COMPATT) refers to a Sonardyne COMPATT located at a known fixed 
point. The configuration of this unit within the Xponder file is independent of the actual device 
interface. The configuration options for this mode option are shown in the following figure. 

 

You are prompted for the information that will enable WinFrog to determine the position of 
the Static Simultaneous COMPATT’s actual transducer. A Static Simultaneous COMPATT 
will most likely be associated with a structure and /or vehicle and thus the configuration 
reflects this. However, it is important to note that the application is not restricted this and 
any position can be entered for the Static Simultaneous COMPATT. The data entry options 
are as follows: 

Name/Position 
Name Entry of the name by which the COMPATT is to be 

known (maximum 24 characters). 
CRP Position The position of the CRP of the structure to which the 

COMPATT is attached. If the COMPATT is not attached 
to a specific structure, the known position of the 
COMPATT’s transducer is entered. The coordinate entry 
is in either Grid or Geographic coordinates depending 
upon which of the Geo or Grid radio buttons is selected. 
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Depth The depth of the CRP of the structure to which the 
COMPATT is attached. If the COMPATT is not 
attached to a specific structure, the known depth of the 
COMPATT’s transducer is entered. 

Orientation The orientation of the structure to which the COMPATT 
is attached. This is entered in either Grid or True 
depending upon which of the Geo or Grid radio buttons 
is selected. If the COMPATT is not attached to a 
specific structure, the position and depth entered is for 
the COMPATT’s transducer and therefore the 
orientation is not required and can be left at 0. 

Pitch The pitch of the structure to which the COMPATT is 
attached. If the COMPATT is not attached to a specific 
structure, the position and depth entered is for the 
COMPATT’s transducer and therefore the pitch is not 
required and can be left at 0. Note that the sign 
convention is bow up, pitch is positive. 

Roll The roll of the structure to which the COMPATT is 
attached. If the COMPATT is not attached to a specific 
structure, the position and depth entered is for the 
COMPATT’s transducer and therefore the roll is not 
required and can be left at 0. Note that the sign 
convention is starboard down, roll is positive. 

F/A Offset The foreward/aft offset from the structure’s CRP to the 
COMPATT’s transducer. Foreward is positive, aft is 
negative. If the COMPATT is not attached to a specific 
structure, the position and depth entered is for the 
COMPATT’s transducer and therefore this offset is not 
required and can be left at 0. 

P/S Offset The port/starboard offset from the structure’s CRP to 
the actual transceiver’s transducer. Starboard is 
positive, port is negative. If the COMPATT is not 
attached to a specific structure, the position and depth 
entered is for the COMPATT’s transducer and 
therefore this offset is not required and can be left at 0. 

U/D Offset The up/down offset from the structure’s CRP to the 
actual transceiver’s transducer. Up is positive, down is 
negative. If the COMPATT is not attached to a specific 
structure, the position and depth entered is for the 
COMPATT’s transducer and therefore this offset is not 
required and can be left at 0. 

Apply Projection Line 
Scale Factor This allows you to apply scaling of offsets to the Map 

Projection before being applied to the CRP position to 
determine the transducer position. In addition, the 
INVERTED LBL data types that use this Xponder will 
check this setting and if it is set, all observations will 
be scaled to the Map Projection before being used. If 
this option is not set, the observations are not scaled 
and the resulting positioning is truly relative. 
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When the above data is entered, WinFrog automatically uses the CRP position and 
depth, orientation, attitude (pitch and roll) and offsets to compute the position and depth 
for the Static Simultaneous COMPATT’s transducer. This data is displayed in the 
bottom of this panel. The position is displayed in either Grid or geographic coordinates 
depending upon which of the Geo or Grid radio buttons is selected. 

The remaining configuration options are the same as those for a Sonardyne COMPATT 
with the exception of the Sensor and Cyclic setup options. 

Configuring the Dynamic Array 
The Dynamic Array refers to a transponder located on a moving vehicle/structure and thus is 
not fixed. The transponder’s offsets with respect to the CRP of the vehicle in the vehicle’s local 
coordinate reference frame are known, but the actual position and depth are unknown. The 
configuration options for this mode option are shown in the following figure. 

 

You are prompted for information that will enable WinFrog to determine a CRP position after 
the position of the transponder’s transducer is determined. 

Name/Position 
Name Entry of the name by which the COMPATT is to be 

known (maximum 24 characters). 
F/A Offset The foreward/aft offset from the structure’s CRP to the 

COMPATT’s transducer. Foreward is positive, aft is negative. 
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P/S Offset The port/starboard offset from the structure’s CRP to 
the actual transceiver’s transducer. Starboard is 
positive, port is negative. 

U/D Offset The up/down offset from the structure’s CRP to the actual 
transceiver’s transducer. Up is positive, down is negative. 

The remaining configuration options are the same as those for a Sonardyne COMPATT 
with the exception of the Sensor and Cyclic setup options. 

Working Control Stations (.CLS) 
The Working Control Stations (.CLS) file is used to store all of the pertinent attributes of a 
reference station. This information is required when using Range/Range peripheral devices. 
Some Range/Range systems (Such as Racal’s MicroFix) are internally configured with the 
control station coordinates and so are able to calculate (and output) a final position. Other 
ranging systems require that the coordinates of the transponders (AKA Control Stations) be 
entered into WinFrog where the final coordinates are then calculated. Control station 
information includes the station’s name, code, position, elevation and calibration values. 

Control stations entered in the Working Control Stations file can also be displayed in 
WinFrog’s Graphics window. 

Creating a Working Control Station (.CLS) File 
To Create a New Working Control Stations File 
The creation and designation of a file as the Working Control Station file is detailed at the 
beginning of this chapter in the Creating and Selecting Less Common Working Files section. 

To Add a Control Station to the Working Control Stations File 
1 From the File menu, choose Edit Working Files... > Control Stations. 

2 Click the Add button. The Control Station dialog box displays, as seen below. 
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3 Highlight the various windows to change the entries, as detailed below: 

Station Identity 
Station Name This can be any identifying name up to 25 

characters. 
Station Code This is the code that the ranging system uses to 

identify the range data in the serial output. For 
example, for the Del Norte Trisponder 540 
DDMU, it is the first two digits of the three-digit 
beacon code. 

Station Coordinates 
Position Enter the station coordinates as referred to the 

current Working Ellipsoid (datum) or the 
current Map Projection. 

Elevation Enter the mean sea level elevation. This is used 
to reduce the slope range to a horizontal 
distance. 

Calibration 
Calibration Enter the calibration value to be added to the 

raw range. 
 

4 Click OK to save the entered data and return to the main Working Control Station dialog 
box. 
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Editing the Working Control Stations File 
You can edit any Control Station parameter via the Working Control Stations File.  

To Edit Parameters in the Working Control Stations File 
1 From the File menu, choose Edit Working Files... > Control Stations. 

The Working Control Stations dialog box contains a listing of all Control Stations in the 
Working Control Stations file. 

2 Select the name of the Control Station that requires editing. 

3 Click Edit. 

4 Highlight the desired entry and make the required changes. 

5 Click OK to save the changes and return to the main Control Station dialog box. 

Removing a Control Station from the Working File 
Any Control Station can be removed from the Working Control Stations File. 

To Remove a Control Station from the Working Control Station File 
1 From the File menu, choose Edit Working Files... > Control Stations. 

2 Select the Control Station File to be removed.  

3 Click the Delete button. 

4 Click OK to save the changes and return to the main Control Station dialog box. 

Working Velocities (.VEL) File 
A Velocities file is used to store a single sound velocity profile. A sound velocity profile is a 
table that contains the speed of sound through water at various water depths. This information is 
essential in the accurate calculation of underwater ranges using acoustic travel times. Sound 
velocity is never constant through a water column and is affected by the temperature, salinity, 
and conductivity of the water. Environmental, oceanographic, and/or meteorological factors 
dictate the rate that sound velocity varies, both spatially and temporally.  

One of the Velocities files must be set to be the Working Velocities (.VEL) file to enable its 
use for the long baseline (LBL) algorithms in WinFrog to convert acoustic travel times into 
actual subsea ranges. An incorrect definition of the sound velocity profile for a work area will 
result in erroneous range calculations and subsequently erroneous subsea positioning. 

Multiple Velocities files may be created, saved and edited. However, only one can be set to be 
the Working Velocities file at any one time. 

Note: The validity of the velocity data is checked upon the loading of a file into WinFrog. If 
loading during boot up and the data fails the validity tests, you are alerted and the file is not 
loaded. If loading from an operator initiated file opening and the data fails the validity tests, you 
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are alerted and the file is loaded. The velocity file check tests that the velocity values are 
between 1420m/s and 1575m/s and that the depths are in sequentially descending order. 

Creating and Opening the Working Velocities File 
The Working Velocities file must first be created or selected before the sound velocity data is 
added. 

To Create a New Velocity File 
The creation of a velocities file is detailed in the Creating and Selecting Less Common 
Working Files section earlier in this chapter.  

In addition, the Velocities file can be created directly from the Acoustic Window via File\ 
New…>Velocity. 

 

In both cases, before the velocities file can be saved to disk, at least one velocity record must be 
added (see To Add a Velocity Record to the Working Velocities File). WinFrog will then 
detect that the document has been altered and prompt you to save it. 

To Open a Velocities File 
The opening of an existing Velocities file is detailed in the Creating and Selecting Less 
Common Working Files section earlier in this chapter. Once open, the file can be edited or 
assigned as the Working Velocities file. Upon the completion of editing, WinFrog will detect 
that changes have been made and prompt you to save the file. 

The Velocities file can be edited even if it is not set to be the Working Velocities file. The 
editing is performed as detailed in Editing the Working Velocities File below. 

To Designate a Velocities File to be the Working Velocities File 
The designation of a Velocity file as the Working Velocities file is detailed in the Creating 
and Selecting Less Common Working Files section earlier in this chapter.  
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In addition, the Velocity file can be set to be the Working Velocities file directly from the 
Acoustic Window via File\ Set to Working…>Velocity. This accesses a browse dialog 
allowing you to find and select the Velocities file to set to the Working Velocities file. When 
done this way, the file is not presented for editing but simply set to be the working file. 

Editing the Working Velocities File 
To Open the Working Velocities File 
1 From the main menu File item, choose Edit Working Files... > Velocities. The Working 

Velocities file will open. 

 Or 

2 From the Acoustic Window File item, choose Edit…> Velocity. The Working Velocities 
file will open. 

To Add a Velocity Record to the Working Velocities File. 
1 Open the Working Velocities file. 

2 Click Add. The Velocity Table dialog box appears, as seen below. 

 

The following information can be modified in the Velocity Table dialog box: 

Depth field Enter the depth of the sound velocity observation. This 
is displayed and entered in the Default Water Depth 
units.  

 NOTE: Depths are entered as positive values. 
Velocity field Enter the sound velocity observation. This is displayed 

and entered in the default Distance units per second. 
3 Enter the appropriate values in these two fields.  

NOTE: Velocities must be between 1420 and 1575 m/s. 

NOTE: All depths must be in the correct sequence starting at the water surface. 

NOTE: All depths must be below the water surface, that is, a negative value cannot 
be entered. 

4 Click OK to confirm these entries and close this window. WinFrog will check the data 
entry and prompt you if it is detected that the entered depth does not fit the descending 
order sequence or the velocity value is outside the above limits. 
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5 Repeat steps 2 to 4 entering depth/velocity to a depth greater than the expected working 
depth. The final depth/velocity entry should be at a depth greater than the maximum 
working depth to ensure that the interpolation of velocities is complete through the entire 
water column. 

To Edit a Velocity Record in the Working Velocities File 
1 Open the Working Velocities file. 

2 Select the entry that requires editing. 

3 Click Edit. Or, 
Double-click the desired record. Or, 
From the Velocity Profile Graph (see Viewing a Velocities File Graphically), double-click 
the desired point. 

4 The same Velocity Table dialog box used to initially add the depth record is opened, 
displaying the current data. Make the desired changes. 

5 Click OK to save the changes and close this window. WinFrog will check the data entry 
and prompt you if it is detected that the entered depth does not fit the descending order 
sequence or the velocity value is outside the above limits. 

To Delete a Velocity Record in the Working Velocities File 
1 Open the Working Velocities file. 

2 Select the entry to be removed.  

3 Click the Delete button. 

4 Click OK to save the changes and close this window. 

Printing a Working Velocities File 
1 Open the Working Velocities file or an existing Velocities file not set to be the Working 

Velocities file. 

2 Click the Print button. This will present the Velocity Profile Print Options dialog. 

Note: The Print button is only enabled if there is at least 1 velocity record in the file. 
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3 Select either Printer or To File option. Selecting Printer results in the print going directly 
to the Windows default printer. If selecting the To File option, you must either enter the 
target file or use the Browse button to locate or enter an appropriate file name. 

4 Click the OK button. This will exit this dialog and execute the appropriate printing. When 
the printing is completed, you will be informed with a message box stating Writing to File 
Finished. 

Viewing a Velocities File Graphically 
This feature allows you to view the velocity data graphically complete with zoom in and out, 
direct data editing and printing features. 

1 Open the Working Velocities file or an existing Velocities file not set to be the Working 
Velocities file. 

2 Click the Graph button. This will present the Velocity Profile dialog. 

Note: The Graph button is only enabled if there are at least two velocity records in the file. 

 

3 Clicking the Zoom In button presents a more detailed view of the data. Note that the 
vertical sliding bar on the left of the window allows you to move up and down the water 
column to view the data. 

4 Clicking the Zoom Out button presents a less detailed view of the data. This button is only 
active if the data has been Zoomed In already. The vertical sliding bar on the left of the 
window allows you to move up and down the water column to view the data if required. 

5 Clicking the Print button presents the Velocity Profile Print Options dialog. 
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i Select either Printer or To File option. Selecting Printer results in the print going 
directly to the Windows default printer. If selecting the To File option, you must 
either enter the target file or use the Browse button to locate or enter an appropriate 
file name. Check the Include Velocity Profile Text Table if you wish to print the 
velocity file data in tabular form with the graphics. 

ii Click the OK button. This will exit this dialog and execute the appropriate printing. 
When the printing is completed, you will be informed with a message box stating 
that Writing to File Finished. 

6 Double-clicking near a data point in the graphics area of the screen will enable you to edit 
the data for the velocity data point nearest the cursor. The Velocity Table dialog box 
appears. 

 

See To Add a Velocity Record to the Working Velocities File for details on entering data 
in this dialog. 

Working Cable Events (.CET) File 
The Working Cable Events (.CET) file is used to store Cable Events generated by the user. 
Cable Events are specifically used for submarine cable lay operations, where they are used to 
record navigation and cable lay slack information at the press of button. For more information 
about Cable Events, see the Eventing chapter. 

The Graphics and Bird’s Eye windows can be configured to display cable events recorded in 
the Working Cable Events file. This provides a graphical record of the cable events logged 
during the survey.  
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Creating the Working Cable Events File 
In order to record cable events, the Working Cable Events file must first be defined. 

To Create a New Working Cable Events File 
The creation and designation of a file as the Working Cable Events file is detailed earlier in 
this chapter in the Creating and Selecting Less Common Working Files section. 

Editing the Working Cable Events File 
Once the Working Cable Events File has been designated and cable events have been 
recorded, it may be necessary to edit the cable events contained in the file. 

To Edit the Contents of the Working Cable Events File 
1 From the File menu, choose Edit Working Files... > Cable Events. 

The Working Cable Events dialog box displays a listing of all cable events contained in 
the Working Cable Events file. 

2 Select the cable event that requires editing.  

3 Click Edit. The same Cable Event dialog box that appeared when the cable event was 
initially taken opens, as seen below. 

 

This dialog box allows you to modify any of the following parameters: 
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Comment entry field Allows you to enter a comment to describe the event. 
Vehicle dropdown menu Allows you to select the vehicle associated with the 

other parameters in this dialog box. 
Time field Indicates the time and date that the cable event was 

taken. 
Position field Indicates the position of the vehicle selected in the 

dropdown menu. 
Water Depth The depth of the water at the vessel when the cable 

event was taken. 
Tension The amount of tension in the cable at the instant that 

the cable event occurred. 

Cable Data 
Source dropdown menu Selects a cable counter peripheral device previously 

added to this vehicle. 
Type dropdown menu Selects the kind of icon that will be used to represent 

the cable event in the Graphics display. The types are 
specific to cable laying jobs: 
KM Mark, Transition, Splice Box, Repeater, Branch, 
Cable End 

 Additional generic options are available, such as 
square, circle, and triangle. 

Route Distance 
Incremental The distance traveled along the route since the 

previous Cable Event. 
Cumulative The distance traveled along the route since the first 

cable event in the Working CET file (i.e. the sum of 
the Incremental Distances). 

Cable Distance 
Incremental The amount of cable let out since the previous cable event. 
Cumulative The amount of cable let out since the first cable event 

in the Working CET file (i.e. the sum of the 
Incremental Distances). 

Percent Slack 
Incremental The calculated amount of slack in the cable since the 

previous cable event. 
Cumulative The calculated amount of slack in the cable since the 

first Cable Event in the Working CET file. 
 

4 Highlight the appropriate data field and make the desired changes. 

5 Click OK to close this dialog and return to the Cable Event Table dialog. 

6 Click OK close this dialog box and save the changes. 
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Deleting a Cable Event 
Any cable event can be removed from the Working Cable Events file. 

To Remove a Cable Event 
1 From the File menu, choose Working... > Cable Events. 

2 Select the record to be removed. 

3 Click the Delete button. 

To Add a Cable Event to the Working Cable Events File. 
Use the following instructions to add Cable Events to the .CET file “after the fact”. See the 
Eventing chapter for details on adding Cable Events to the .CET table in “real-time”. 

1 From the File menu, choose Edit Working Files... > Cable Events. 

2 Click Add. The same Cable Event dialog box opens as when a cable event is taken or 
when a record is edited. 

3 Configure the various parameters, as detailed above. 

4 Click OK to close this window. 

5 Click OK to close the Cable Events Table and to save the changes made. 
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